Asking for help

Questions seeking answers can be found here, someone else may have had the same issue and might have a solution.
Forum rules
BEFORE YOU POST...

Remember that mods you download that are created by Davo REQUIRE Spore: Galactic Adventures and REQUIRE your game to be installed & patched in this order.
  • - Install Spore Game
  • - (OPTIONAL) Install Spore C&C
  • - Install Spore Galactic Adventures
  • - Patch Spore and Spore Galactic Adventures to 1.5.1
If you have any further questions, feel free to ask.
User avatar
Ivihun
Hatchling
Hatchling
Posts: 4
Joined: Tue Mar 02, 2021 10:42 am

Asking for help

Unread post by Ivihun »

Hello there! I have a bit of a problem with Spore ModAPI. When I want to open the game through the launcher, it first ask me if I want to update it. When I click No, everything goes normal and everything works. But here is the problem: When I press Yes, it updates the ModAPI just as it said it would. Everything works except one thing. When I want to create an Adventure with the editor and try to save it, it just saves forever and I can't click or press anything. I reinstalled the ModAPI kit and without updating it, it worked perfectly fine again.
It causes some trouble because many mods require the ModAPI to be updated, like Infinite scaling.
I would be really happy if it worked, I am a big Adventure editor expert.
Thank you for your answers.


User avatar
Ivihun
Hatchling
Hatchling
Posts: 4
Joined: Tue Mar 02, 2021 10:42 am

Re: Adventures won't save after updating ModAPI

Unread post by Ivihun »

Ivihun wrote: Mon Jul 04, 2022 7:42 am Hello there! I have a bit of a problem with Spore ModAPI. When I want to open the game through the launcher, it first ask me if I want to update it. When I click No, everything goes normal and everything works. But here is the problem: When I press Yes, it updates the ModAPI just as it said it would. Everything works except one thing. When I want to create an Adventure with the editor and try to save it, it just saves forever and I can't click or press anything. I reinstalled the ModAPI kit and without updating it, it worked perfectly fine again.
It causes some trouble because many mods require the ModAPI to be updated, like Infinite scaling.
I would be really happy if it worked, I am a big Adventure editor expert.
Thank you for your answers.
Post Reply Previous topicNext topic

Return to “Help”