Core Spore Editor UI Broken

Found a bug in a 9.r beta? Let us know here, so we can fix it.
Forum rules
1. Please post only ONE bug per THREAD. If you have multiple bugs to report, create a thread FOR EACH BUG.

2. Please NAME your THREADS as DESCRIPTIVELY as possible.

3. Please DO NOT CREATE report threads for bugs which have already been reported. This produces REDUNDANT BUG REPORTS, which slows down development by making it harder for me to read, reports and fix the bugs mentioned within them. This also applies for bugs which have been fixed and moved accordingly, so CHECK the FIXED BUGS subforum BEFORE POSTING. Previously-submitted bug reports can be found here: http://www.davoonline.com/phpBB3/viewforum.php?f=174
User avatar
SeriousMANBOT
Cell
Cell
Posts: 7
Joined: Thu Nov 29, 2018 3:05 pm

Core Spore Editor UI Broken

Unread post by SeriousMANBOT »

When using the UI styles "Style Only", "Shimmer", "Half Black", and Core Spore UI, the creature editor defaults to the page with the random joke parts, which is fine (though looks bizzare)
Image

However when I select a category on the top left, the correct parts appear, however it shows the incorrect category at the top (in this case, pressing mouths selects graspers while still showing mouth parts)
Image

W̶h̶i̶l̶e̶ ̶a̶t̶ ̶f̶i̶r̶s̶t̶ ̶t̶h̶i̶s̶ ̶a̶p̶p̶e̶a̶r̶s̶ ̶t̶o̶ ̶b̶e̶ ̶a̶ ̶v̶i̶s̶u̶a̶l̶ ̶g̶l̶i̶t̶c̶h̶,̶ ̶i̶t̶ ̶a̶c̶t̶u̶a̶l̶l̶y̶ ̶m̶a̶k̶e̶s̶ ̶t̶h̶e̶ ̶D̶e̶t̶a̶i̶l̶s̶ ̶p̶a̶g̶e̶ ̶c̶o̶m̶p̶l̶e̶t̶e̶l̶y̶ ̶i̶n̶a̶c̶c̶e̶s̶s̶i̶b̶l̶e̶,̶ ̶a̶s̶ ̶c̶l̶i̶c̶k̶i̶n̶g̶ ̶i̶t̶ ̶a̶c̶t̶u̶a̶l̶l̶y̶ ̶c̶h̶a̶n̶g̶e̶s̶ ̶t̶o̶ ̶t̶h̶e̶ ̶n̶e̶x̶t̶ ̶p̶a̶g̶e̶ ̶o̶f̶ ̶p̶a̶r̶t̶ ̶c̶a̶t̶e̶g̶o̶r̶i̶e̶s̶ ̶a̶n̶d̶ ̶s̶h̶o̶w̶s̶ ̶t̶h̶e̶ ̶p̶a̶r̶t̶s̶ ̶f̶r̶o̶m̶ ̶t̶h̶e̶ ̶f̶i̶r̶s̶t̶ ̶c̶a̶t̶e̶g̶o̶r̶y̶ ̶i̶n̶ ̶t̶h̶a̶t̶ ̶p̶a̶g̶e̶
(EDIT: I just realized while it does show the incorrect page and category, the detail parts are still accessible, so this is mostly just a visual glitch. Please excuse my dumbness, I don't do bug reports often :oops: )
As far as I know this issue is only present in the creature editor (and the extra "***" colonist editor) and isn't present when using the DarkSpore and Beta DarkSpore UI styles, but is a major issue nonetheless

I am running what I'm assuming is the latest version of Dark Injection, which I installed a few days ago from the website.
I hope this report is seen, for now I'll just have to switch between the two UI styles lol


Image
me when I see a cool spore mod
User avatar
rob55rod
Admin
Admin
Posts: 4086
Joined: Sat Jul 02, 2011 9:50 am

Re: Core Spore Editor UI Broken

Unread post by rob55rod »

Huh...do you have any other mods installed? If so, what are they?
Having trouble with the Spore ModAPI Launcher Kit? Get help here!

If you're reading this, you have my permission to build off of my mods as long as I am credited. Please don't mirror my work unaltered, unless I no longer provide a working download.
User avatar
SeriousMANBOT
Cell
Cell
Posts: 7
Joined: Thu Nov 29, 2018 3:05 pm

Re: Core Spore Editor UI Broken

Unread post by SeriousMANBOT »

rob55rod wrote: Wed May 25, 2022 12:11 pm Huh...do you have any other mods installed? If so, what are they?
yeah I have a lot of mods installed, here's all of the ones I have (although some of them aren't functional and I just forgot to remove them when testing)

Core Spore folder (Data)
Image

GA folder (DataEP1)
Image

I don't think this issue is caused my conflicting mods, however I don't see an option to disable the "joke parts" in the ModAPI installer
any help would be appreciated, thank you for responding to the original message
Image
me when I see a cool spore mod
User avatar
SeriousMANBOT
Cell
Cell
Posts: 7
Joined: Thu Nov 29, 2018 3:05 pm

Re: Core Spore Editor UI Broken

Unread post by SeriousMANBOT »

clicking any of the last few part categories causes the game to immediately crash
here's a video demonstrating the glitch in action, I don't know if there's a .package file I need to delete or if this is something everyone is experiencing, but as far as I know I'm the only one with this issue (as usual)


STAFF EDIT: Fixed YouTube video embed
Image
me when I see a cool spore mod
Post Reply Previous topicNext topic

Return to “DI 9.r Bug Reports”