Spore ModAPI

Download tools and get the latest patches.
User avatar
Fran the Enby Folk
Hatchling
Hatchling
Posts: 1
Joined: Mon Sep 13, 2021 4:28 pm

Re: Spore ModAPI

Unread post by Fran the Enby Folk »

Cornucopia wrote: Sat Sep 11, 2021 12:39 pm (obligatory "I made an account just to ask one question" comment)

Alrightie, so I was able to get the ModAPI to work with every mod EXCEPT for ones that much be launched via the Launcher (aka Dark Injections, in this case)

Whenever I launch the game after installing Dark Injections, it tells me to launch the game via the ModAPI. Which... I'm already doing. When I uninstall Dark Injections, Spore opens fine. It will run all my other mods except Dark Injection, which is a pain since I love to use Dark Injections for infinite complexity (and I do not believe there's a working mod out there for just that, if there is that please tell me lol)

For some more information: I am using the Steam edition of Spore, have both DLCs, and have used Dark Injections just fine on Spore before. This only began happening after I had wiped my computer (to fix some technical issues), reinstalled API and Spore, and I attempted to use the API after a reset (yes, it was working fine until I reset my computer for a Windows update. Thanks, Windows!). I have attempted to uninstall and reinstall the API, Spore, and Dark Injections before, however this didn't change anything. Can't really find anymore comments about some sort of issue similar to this...
So, I've been having the same issue, as long as most of the posts in here and what i did was add the modapi launcher to steam and apparently worked:

The option is on the bottom left corner, you select "add a non-steam game..." and then browse for the launcher and the just start it from steam (i added the original, not the shortcut, idk of it works with the desktop shortcut), make sure to remove admin privileges from steam and then it should work.

I hope it works for everyone else.


User avatar
CoolDude905
Hatchling
Hatchling
Posts: 1
Joined: Sat Sep 18, 2021 3:48 pm

Re: Spore ModAPI

Unread post by CoolDude905 »

User avatar
Potatoad
Hatchling
Hatchling
Posts: 1
Joined: Tue Sep 14, 2021 8:52 am

Re: Spore ModAPI

Unread post by Potatoad »

I keep getting a data is corrupt or missing and now my spore wont even open without the mods. this game is a real pain in the sassafrass ill tell ya
User avatar
UltimateWalrus5
Hatchling
Hatchling
Posts: 1
Joined: Sun Sep 26, 2021 9:28 am

Re: Spore ModAPI

Unread post by UltimateWalrus5 »

I'm having an issue with the MODAPI launcher. I bought the game and both DLC's on Origin and have the latest version of the API launcher

First of all if i close spore, it will produce an error message telling me to close spore before opening the API launcher despite having done so.

I can fix this issue by restarting my computer but after this i get another error when trying to run the API launcher that says :
Attachments
Screenshot 2021-09-26 163442.png
User avatar
Poob
Hatchling
Hatchling
Posts: 1
Joined: Sat Oct 02, 2021 10:44 pm

Re: Spore ModAPI

Unread post by Poob »

the following errors appear when I try to open the launcher

Image
Image
Image
Image

I am using the steam version of spore.
User avatar
Vionn
Hatchling
Hatchling
Posts: 1
Joined: Sun Oct 03, 2021 10:15 pm

Re: Spore ModAPI

Unread post by Vionn »

It says I'm using an unsupported version of spore and that I should download version 3.1.0.22 of spore even though I'm already using the GoG version 3.1.0.22 of Spore , please help me.
Attachments
yes.png
User avatar
CockBastard
Hatchling
Hatchling
Posts: 1
Joined: Sun Oct 03, 2021 8:00 pm

Re: Spore ModAPI

Unread post by CockBastard »

Got this while trying to run Spore from the ModAPI Launcher. It happens when I try to launch from there no matter whether I have mods installed or not. The game can launch from the normal launcher as long as I don’t have mods installed.

I have the “SporeModAPI.lib” in the core libs folder but it says it can’t find it in the mLibs folder. I tried copy pasting it into that folder but that didn’t work.
Attachments
image.jpg
User avatar
GutRippa
Hatchling
Hatchling
Posts: 3
Joined: Sun Oct 17, 2021 2:21 pm

Re: Spore ModAPI

Unread post by GutRippa »

Yeah, maybe you should just delete this if everyone's having issues getting it to work anymore. Otherwise, fix your crap.
User avatar
rob55rod
Admin
Admin
Posts: 4085
Joined: Sat Jul 02, 2011 9:50 am

Re: Spore ModAPI

Unread post by rob55rod »

GutRippa wrote: Wed Oct 20, 2021 12:36 pmYeah, maybe you should just delete this if everyone's having issues getting it to work anymore. Otherwise, fix your crap.
Actually, I've been trying to "fix" this "crap" this whole time.I apologize for my...abysmal failure of communication though. That was wrong of me.

I just...can't bear to make a promise I can't keep. I do see how...frustrated everyone is here, and that's the last thing I want. But it would be irresponsible of me to come out here and imply I've fixed everything when that's not the case, would it not?

That said...progress is being made. I can't promise what will or won't be fixed, but I am doing everything I can here. Heck, I now own Spore on Steam, which I'm hoping may shed some light on that can of worms - many of these problems only affect the Steam version of the game, after all.
I don't think I can safely say that everything is or will be fixed though, that would be...disingenuous of me.

Before anyone asks why I'm not sending fixes out as they happen...it's because they're not happening to the current Spore ModAPI Launcher Kit codebase, but to its long-overdue rewrite, which I've been working on for nearly four years now. The Launcher Kit was...written in a rush, to get it out the door so it wouldn't have to be touched ever again. That was a mistake, and it's made resolving these issues a lot harder. That's one reason why, even after receiving the source code, I concluded I'd still have to rewrite it. I'd considered trying to backport some of my findings, but...after how badly the last time I tried to do so went, I suspect that would only make things worse.


I want these problems solved. Every last one of them, if possible. Will that ever happen? I don't know...and knowing how Spore is, I doubt it. But some will be resolved - some already have been - and no amount of improbability will stop me from trying to address the rest. That's not a promise of results, but it is a promise of attempt.


Thank you for holding me accountable for my failures, by the way. Quality assurance has become a dying art in recent years, because nobody is held accountable anymore.

Now, I'm going to ask you and anyone else who may read this...to not push for a premature release. I can't afford to rush this, especially not this late in the game. That will only land us all right back where we are now: dealing with broken crap. Quality, unfortunately, takes time. Four years? Maybe not...if I were a competent programmer...but I'm not. I'm just the only one who's insane enough to not give up.

Thank you.
Having trouble with the Spore ModAPI Launcher Kit? Get help here!

If you're reading this, you have my permission to build off of my mods as long as I am credited. Please don't mirror my work unaltered, unless I no longer provide a working download.
User avatar
Tawret
Hatchling
Hatchling
Posts: 2
Joined: Sun Oct 17, 2021 9:59 am

Re: Spore ModAPI

Unread post by Tawret »

rob55rod wrote: Wed Oct 20, 2021 9:48 pm
GutRippa wrote: Wed Oct 20, 2021 12:36 pmYeah, maybe you should just delete this if everyone's having issues getting it to work anymore. Otherwise, fix your crap.
Actually, I've been trying to "fix" this "crap" this whole time.I apologize for my...abysmal failure of communication though. That was wrong of me.

I just...can't bear to make a promise I can't keep. I do see how...frustrated everyone is here, and that's the last thing I want. But it would be irresponsible of me to come out here and imply I've fixed everything when that's not the case, would it not?

That said...progress is being made. I can't promise what will or won't be fixed, but I am doing everything I can here. Heck, I now own Spore on Steam, which I'm hoping may shed some light on that can of worms - many of these problems only affect the Steam version of the game, after all.
I don't think I can safely say that everything is or will be fixed though, that would be...disingenuous of me.

Before anyone asks why I'm not sending fixes out as they happen...it's because they're not happening to the current Spore ModAPI Launcher Kit codebase, but to its long-overdue rewrite, which I've been working on for nearly four years now. The Launcher Kit was...written in a rush, to get it out the door so it wouldn't have to be touched ever again. That was a mistake, and it's made resolving these issues a lot harder. That's one reason why, even after receiving the source code, I concluded I'd still have to rewrite it. I'd considered trying to backport some of my findings, but...after how badly the last time I tried to do so went, I suspect that would only make things worse.


I want these problems solved. Every last one of them, if possible. Will that ever happen? I don't know...and knowing how Spore is, I doubt it. But some will be resolved - some already have been - and no amount of improbability will stop me from trying to address the rest. That's not a promise of results, but it is a promise of attempt.


Thank you for holding me accountable for my failures, by the way. Quality assurance has become a dying art in recent years, because nobody is held accountable anymore.

Now, I'm going to ask you and anyone else who may read this...to not push for a premature release. I can't afford to rush this, especially not this late in the game. That will only land us all right back where we are now: dealing with broken crap. Quality, unfortunately, takes time. Four years? Maybe not...if I were a competent programmer...but I'm not. I'm just the only one who's insane enough to not give up.

Thank you.

Best of luck to you! I believe that you will do your best to "fix" these issues with the Spore ModAPI, keep up the effort and I am sure you'll be satisfied by the end of it, I think I can speak for every Spore ModAPI user here and say that we are cheering you on. Thanks for your time and effort :D
User avatar
Mystere
Hatchling
Hatchling
Posts: 2
Joined: Thu Oct 14, 2021 12:58 am

Re: Spore ModAPI

Unread post by Mystere »

Hi I'm replying to the newest post because I need help with something, but I don't know how to create my own post, can someone please help me?
User avatar
k0tter1
Hatchling
Hatchling
Posts: 2
Joined: Thu Mar 22, 2018 11:57 pm
Age: 20

Re: Spore ModAPI

Unread post by k0tter1 »

Hey there, I saw an old thread reply asking this question but I was wondering if there was a fix. I have both the latest update Steam version and a torrented GOG version of Spore and I'm getting the "please update to 3.1.0.22" message.
User avatar
oddblank_
Hatchling
Hatchling
Posts: 1
Joined: Mon Nov 01, 2021 12:43 am

Re: Spore ModAPI

Unread post by oddblank_ »

Hi there, made an account to ask if there is a fix to my particular brand of error. To start, the Launcher Kit Setup doesn't actually run anything when double clicked. Opening task manager reveals that the setup program does actually open for .3 seconds, but so does windows error reporter. Nothing actually shows up so I don't get any sort of error message.

Im using the GOG version of spore, with all dlc. I'm on windows 10, not sure if it matters but i wouldnt be surprised if thats the culprit.
User avatar
Redwhitedragen
Hatchling
Hatchling
Posts: 1
Joined: Mon Nov 01, 2021 8:07 am

Re: Spore ModAPI

Unread post by Redwhitedragen »

So I got a GOG version of Spore, and the game runs fine without mods. But my problem is that when I open the Spore ModAPI Launcher it says, "If you're using the Steam version of Spore or the GOG version of Spore, please update to version 3.1.0.22 to proceed. If you're using Origin Spore and you see this message, or if you're already using a higher version of Spore, please inform rob55rod or emd4600 immediately." And my Spore is updated to the latest update it can be.
User avatar
abdel2222
Hatchling
Hatchling
Posts: 1
Joined: Wed Dec 31, 2014 10:52 am
Age: 21

Re: Spore ModAPI

Unread post by abdel2222 »

here is my case, I have spore since 2009 and I had the original physical disks, but I lost them although I keep the isos, but I wanted to try spore in origin and torrent it because I have not been able to skip the dmr, my problem is that after installing the mod api I always get these windows and it does not start
Image
Image
Image
User avatar
ZG
Hatchling
Hatchling
Posts: 1
Joined: Sun Nov 07, 2021 6:23 am

Re: Spore ModAPI

Unread post by ZG »

Hey joined cuz I'm also getting errors.
installed on Origin
Spore, creepy and GA
using windows 10

Error: 2


Image
User avatar
arkzmuto
Hatchling
Hatchling
Posts: 2
Joined: Thu Nov 11, 2021 7:56 pm

Re: Spore ModAPI

Unread post by arkzmuto »

I reinstalled spore, and the mod api, but now it says i have an unsupported version. It used to work before, so i think an update just came up coincidentally. If so, how do i update? i know a pop-up used to show whenever i install a mod, reminding me whenever there's an update, but it hasn't shown up yet.
User avatar
arkzmuto
Hatchling
Hatchling
Posts: 2
Joined: Thu Nov 11, 2021 7:56 pm

Re: Spore ModAPI

Unread post by arkzmuto »

Had to reinstall spore and the mod api, and now it doesn't work. It said i needed to update, but im already using the highest version, and said to contact rob/emd?
User avatar
ssssssssssssssssa
Hatchling
Hatchling
Posts: 1
Joined: Tue Nov 16, 2021 3:57 pm

Re: Spore ModAPI

Unread post by ssssssssssssssssa »

Hello gamers. after coming back to this game since I was in 3rd or 4th grade, I got the game on steam, and origin. I decided to download a couple of mods, one of them namely being dark injections. first time playing, the game was mostly fine, except for a weird error with some of the mouth part models not appearing in game. there were also a couple of mods miscellaneous mods that weren't showing up whatsoever. (probably a when I tried to open the steam version of the game on startup, I got these error messages.
:(
:(
Screenshot 2021-11-16 161719.png (4.09 KiB) Viewed 278 times
):
):
I have a feeling this is related to my use of the Steam version of the game, but unfortunately, that's another problem. I cant actually open the origin version of the game for some reason. In addition to this, I don't have the galactic adventures version of the game on origin. although I'm aware that you can transfer DLCs, (not sure how though), I'm not entirely positive it'll do anything, as the base game doesn't work as it is.

Ill try to reply as soon as possible to anyone who wants to inquire with my problem further, but incase I don't reach out, here's my discord: may i #4755.

thanks for (probably) reading.
User avatar
Davo
The Boss
The Boss
Posts: 2216
Joined: Sun Dec 27, 2009 1:36 am
Age: 37

Re: Spore ModAPI

Unread post by Davo »

I have recently gotten back to the the game lately, but i would check other topics on this issue, seems to be a common screenshot(the big one) so i know there are many places, like my discord where users have had that issue. hope this helps but i am like 10 years retired on spore but the mod makers do run the forum more than me.
Post Reply Previous topicNext topic

Return to “Tools & Patches”