Official Dark Injection FAQ! Answers and Fixes!

Here you can find information regarding Dark Injection, or post questions if you need further help.
User avatar
rob55rod
Tech Support
Tech Support
Posts: 4069
Joined: Sat Jul 02, 2011 9:50 am
Gender:

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread post by rob55rod »

Langooseondaloose! wrote:
rob55rod wrote:When you turn on your computer, what name do you click before you see your desktop?
So it's the name I click when I turn on my computer? That must be my admin account then. Now that I know, what do I do now?
Is the name in question "Administrator"?
xfreakazoidx wrote:Hi! My first time on here. Been playing Spore forever. So a few days ago I installed Spore (and Spore Galactic Adventures) (from Origin). This is a new hard drive if it helps so never been installed on it before. I downloaded Dark Injector and the Spore API. Installed DI no problem. But in game nothings seems to have changed like in the examples it gives you during installation. Did I do something wrong?

On a side note, does the complexity part of the mod let you use UFOs (for example) that are over the complexity limit? I know back then you couldn't. Thanks
Have you previously had the game installed from somewhere other than Origin on your previous hard drive?
Having trouble with the Spore ModAPI Launcher Kit? Get help here!

If you're reading this, you have my permission to build off of my mods as long as I am credited. Please don't mirror my work unaltered, unless I no longer provide a working download.
xfreakazoidx
Poster of the New User Apocalypse
Poster of the New User Apocalypse
Posts: 2
Joined: Tue Jun 02, 2020 6:33 pm

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread post by xfreakazoidx »

xfreakazoidx wrote:Hi! My first time on here. Been playing Spore forever. So a few days ago I installed Spore (and Spore Galactic Adventures) (from Origin). This is a new hard drive if it helps so never been installed on it before. I downloaded Dark Injector and the Spore API. Installed DI no problem. But in game nothings seems to have changed like in the examples it gives you during installation. Did I do something wrong?

On a side note, does the complexity part of the mod let you use UFOs (for example) that are over the complexity limit? I know back then you couldn't. Thanks
Have you previously had the game installed from somewhere other than Origin on your previous hard drive?[/quote]
Nope.
User avatar
Scootgami
Recruit
Recruit
Posts: 9
Joined: Sat May 30, 2020 12:15 pm

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread post by Scootgami »

Okay, I have no idea how I got this to work, but now all the sounds are back and I am able to ally other tribes.

However, even with the mod installed, I am not able to access my creations made with the mod's parts. I have everything installed (at least I believe I do). What am I missing here?
User avatar
rob55rod
Tech Support
Tech Support
Posts: 4069
Joined: Sat Jul 02, 2011 9:50 am
Gender:

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread post by rob55rod »

Scootgami wrote:Okay, I have no idea how I got this to work, but now all the sounds are back and I am able to ally other tribes.

However, even with the mod installed, I am not able to access my creations made with the mod's parts. I have everything installed (at least I believe I do). What am I missing here?
What do you mean when you say you're "not able to access" your creations made with DI's parts? Is there a padlock icon on the Sporepedia cards for them?
Having trouble with the Spore ModAPI Launcher Kit? Get help here!

If you're reading this, you have my permission to build off of my mods as long as I am credited. Please don't mirror my work unaltered, unless I no longer provide a working download.
User avatar
Scootgami
Recruit
Recruit
Posts: 9
Joined: Sat May 30, 2020 12:15 pm

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread post by Scootgami »

rob55rod wrote:
Scootgami wrote:Okay, I have no idea how I got this to work, but now all the sounds are back and I am able to ally other tribes.

However, even with the mod installed, I am not able to access my creations made with the mod's parts. I have everything installed (at least I believe I do). What am I missing here?
What do you mean when you say you're "not able to access" your creations made with DI's parts? Is there a padlock icon on the Sporepedia cards for them?
Yep, there is a padlock icon. If I wish to view the creation, it says I do not have what is installed.
User avatar
rob55rod
Tech Support
Tech Support
Posts: 4069
Joined: Sat Jul 02, 2011 9:50 am
Gender:

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread post by rob55rod »

Scootgami wrote:Yep, there is a padlock icon. If I wish to view the creation, it says I do not have what is installed.
Right...that sometimes happens if you run Spore after uninstalling the mods a creation requires. Sometimes the game doesn't notice if you reinstall the mods.
Having trouble with the Spore ModAPI Launcher Kit? Get help here!

If you're reading this, you have my permission to build off of my mods as long as I am credited. Please don't mirror my work unaltered, unless I no longer provide a working download.
User avatar
Scootgami
Recruit
Recruit
Posts: 9
Joined: Sat May 30, 2020 12:15 pm

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread post by Scootgami »

rob55rod wrote:
Scootgami wrote:Yep, there is a padlock icon. If I wish to view the creation, it says I do not have what is installed.
Right...that sometimes happens if you run Spore after uninstalling the mods a creation requires. Sometimes the game doesn't notice if you reinstall the mods.
Ah okay. Do I just need to reinstall it again?
User avatar
rob55rod
Tech Support
Tech Support
Posts: 4069
Joined: Sat Jul 02, 2011 9:50 am
Gender:

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread post by rob55rod »

Scootgami wrote:
rob55rod wrote:
Scootgami wrote:Yep, there is a padlock icon. If I wish to view the creation, it says I do not have what is installed.
Right...that sometimes happens if you run Spore after uninstalling the mods a creation requires. Sometimes the game doesn't notice if you reinstall the mods.
Ah okay. Do I just need to reinstall it again?
...I'd thought you were implying you already had. Yes, absolutely do that.
Having trouble with the Spore ModAPI Launcher Kit? Get help here!

If you're reading this, you have my permission to build off of my mods as long as I am credited. Please don't mirror my work unaltered, unless I no longer provide a working download.
User avatar
Scootgami
Recruit
Recruit
Posts: 9
Joined: Sat May 30, 2020 12:15 pm

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread post by Scootgami »

rob55rod wrote:
Scootgami wrote:
rob55rod wrote: Right...that sometimes happens if you run Spore after uninstalling the mods a creation requires. Sometimes the game doesn't notice if you reinstall the mods.
Ah okay. Do I just need to reinstall it again?
...I'd thought you were implying you already had. Yes, absolutely do that.
I've reinstalled the mod, but the padlock icons remain unfortunately.

I apologize, I'm not that good with computers ^^'
User avatar
rob55rod
Tech Support
Tech Support
Posts: 4069
Joined: Sat Jul 02, 2011 9:50 am
Gender:

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread post by rob55rod »

Scootgami wrote:I've reinstalled the mod, but the padlock icons remain unfortunately.
Then you've been screwed over by caching, unfortunately. Sorry. Best hope they disappear on their own eventually, which they may or may not.
Scootgami wrote:I apologize, I'm not that good with computers ^^'
Don't worry about that, lol
Having trouble with the Spore ModAPI Launcher Kit? Get help here!

If you're reading this, you have my permission to build off of my mods as long as I am credited. Please don't mirror my work unaltered, unless I no longer provide a working download.
User avatar
Langooseondaloose!
Recruit
Recruit
Posts: 24
Joined: Fri Jun 22, 2018 8:18 pm

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread post by Langooseondaloose! »

rob55rod wrote: Is the name in question "Administrator"?
Nope! That's not normal, is it?
Who let the langoose out? Me.
jahbkjashdoisadyfuio
Poster of the New User Apocalypse
Poster of the New User Apocalypse
Posts: 2
Joined: Tue Jun 23, 2020 4:02 pm

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread post by jahbkjashdoisadyfuio »

please mention and installing error...
this happened a lot for me and i dont know why..i have the most recent DI and i have sporemod api, heres a screenshot
wanted to blur my name so, sorry if you're confused!
Attachments
Annotation 2020-07-11 163646.png
User avatar
TheRealMaxolotl
Poster of the New User Apocalypse
Poster of the New User Apocalypse
Posts: 1
Joined: Mon Jul 13, 2020 3:08 pm

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread post by TheRealMaxolotl »

When I go to launch it, it opens spore for a second, then closes itself. It does not report any kind of crash. I was never given an error message, but the log says there was a problem with the API Origin patch. I'm still working to resolve this.
Maxolotl#7089 on Discord
User avatar
rob55rod
Tech Support
Tech Support
Posts: 4069
Joined: Sat Jul 02, 2011 9:50 am
Gender:

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread post by rob55rod »

TheRealMaxolotl wrote:When I go to launch it, it opens spore for a second, then closes itself. It does not report any kind of crash. I was never given an error message, but the log says there was a problem with the API Origin patch. I'm still working to resolve this.
Can you please show me this log?
Having trouble with the Spore ModAPI Launcher Kit? Get help here!

If you're reading this, you have my permission to build off of my mods as long as I am credited. Please don't mirror my work unaltered, unless I no longer provide a working download.
fabell
Poster of the New User Apocalypse
Poster of the New User Apocalypse
Posts: 1
Joined: Mon Aug 03, 2020 12:15 am

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread post by fabell »

I know this fourm is pretty old, I just hope someone still sees this.. Now, I'm gonna sound really dumb but... I somehow accidently changed the file type of the mod now the API wont read it. I dont know what type of file to change it back to or how to restore it to it's previous version. I tried the properties to restore it but that wasnt an option. I also tried deleting it and reinstalling it, but it just reinstalled as the wrong type??!
Can someone please help me fix this?
User avatar
Langooseondaloose!
Recruit
Recruit
Posts: 24
Joined: Fri Jun 22, 2018 8:18 pm

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread post by Langooseondaloose! »

New problem I found: My spore opens for a bit, then closes. I have no idea why. Kind of similar to the person above me
Who let the langoose out? Me.
User avatar
UglyDollFan
First Class
First Class
Posts: 57
Joined: Sat Jan 09, 2016 10:51 pm
Gender:
Age: 18

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread post by UglyDollFan »

fabell wrote: Mon Aug 03, 2020 12:22 am I know this fourm is pretty old, I just hope someone still sees this.. Now, I'm gonna sound really dumb but... I somehow accidently changed the file type of the mod now the API wont read it. I dont know what type of file to change it back to or how to restore it to it's previous version. I tried the properties to restore it but that wasnt an option. I also tried deleting it and reinstalling it, but it just reinstalled as the wrong type??!
Can someone please help me fix this?
What's the name of that mod you've just changed?
What was the file type you changed it to?
Image
User avatar
Langooseondaloose!
Recruit
Recruit
Posts: 24
Joined: Fri Jun 22, 2018 8:18 pm

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread post by Langooseondaloose! »

Hi it's me again. I decided to update my ModAPI launcher and now it gives me these messages Whenever I try opening it;
Image
Image
The problems never seem to end for me. :|
Who let the langoose out? Me.
Post Reply

Return to “FAQ, Info, and Help”