Using Spore ModAPI Launcher but it says it's not detecting it

For all those problems people post here that aren't actually related to Dark Injection. No hard feelings - I'd rather risk a few misdiagnosis than miss out on real Dark Injection issues someone wasn't 100% sure about.
User avatar
Smile Dog
Recruit
Recruit
Posts: 14
Joined: Sun Jan 20, 2019 11:15 am

Using Spore ModAPI Launcher but it says it's not detecting it

Unread postby Smile Dog » Sat Feb 16, 2019 4:02 pm

Graphics are working fine, and when I reach the galaxy screen it says something like "Please reopen Spore through the Spore ModAPI Launcher. If you are already using the Spore ModAPI Launcher, seek assistance on DavoOnline." So I sought assistance here. I am using the launcher, and I downloaded Spore from a disk. I have all the required downloads, and I even downloaded the newest version of DI.9r but it still says the error message? I can't find any screenshots that I take.. If this has already been solved, sorry, I can't find the "fixed bugs" subforum.

User avatar
rob55rod
Tech Support
Tech Support
Sergeant Major of the Davo Army
Sergeant Major of the Davo Army
Posts: 3869
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.

Re: Using Spore ModAPI Launcher but it says it's not detecting it

Unread postby rob55rod » Sun Feb 17, 2019 5:38 am

Do any other error messages appear?
Having trouble with the Spore ModAPI Launcher Kit? Let us know here!

If you're reading this, you have my permission to build off of my mods as long as I am credited. Please don't mirror my work unaltered, unless I no longer provide a working download.

User avatar
Smile Dog
Recruit
Recruit
Posts: 14
Joined: Sun Jan 20, 2019 11:15 am

Re: Using Spore ModAPI Launcher but it says it's not detecting it

Unread postby Smile Dog » Sun Feb 17, 2019 7:30 am

Not in the game, but in the Spore ModAPI Launcher, it always says "DetourTransactionCommit error: 9" (and if I click OK, it opens Spore) no matter what mod I'm installing. If I wait a little, a huge window appears and says "SporeModAPI_Launcher.InjectException" and "Wait for single object failed." and a bunch of other things I can't copy because I'm too lazy. Does this have anything to do with it?

User avatar
rob55rod
Tech Support
Tech Support
Sergeant Major of the Davo Army
Sergeant Major of the Davo Army
Posts: 3869
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.

Re: Using Spore ModAPI Launcher but it says it's not detecting it

Unread postby rob55rod » Sun Feb 17, 2019 10:26 am

Daamoose wrote:Not in the game, but in the Spore ModAPI Launcher, it always says "DetourTransactionCommit error: 9" (and if I click OK, it opens Spore) no matter what mod I'm installing. If I wait a little, a huge window appears and says "SporeModAPI_Launcher.InjectException" and "Wait for single object failed." and a bunch of other things I can't copy because I'm too lazy. Does this have anything to do with it?

Definitely relevant. Can you provide screenshots of these error messages?
Having trouble with the Spore ModAPI Launcher Kit? Let us know here!

If you're reading this, you have my permission to build off of my mods as long as I am credited. Please don't mirror my work unaltered, unless I no longer provide a working download.

User avatar
Smile Dog
Recruit
Recruit
Posts: 14
Joined: Sun Jan 20, 2019 11:15 am

Re: Using Spore ModAPI Launcher but it says it's not detecting it

Unread postby Smile Dog » Sun Feb 17, 2019 11:29 am

Unfortunately, no, the screenshots I take are probably stored away somewhere in Windows Explorer where I'll never find them.

User avatar
rob55rod
Tech Support
Tech Support
Sergeant Major of the Davo Army
Sergeant Major of the Davo Army
Posts: 3869
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.

Re: Using Spore ModAPI Launcher but it says it's not detecting it

Unread postby rob55rod » Sun Feb 17, 2019 7:09 pm

Daamoose wrote:Unfortunately, no, the screenshots I take are probably stored away somewhere in Windows Explorer where I'll never find them.

Well I need to see the problem one way or another, so...maybe save them in a known location next time?
Having trouble with the Spore ModAPI Launcher Kit? Let us know here!

If you're reading this, you have my permission to build off of my mods as long as I am credited. Please don't mirror my work unaltered, unless I no longer provide a working download.


Return to “Misdiagnosis”