New Client & Broken Mods

Talk about mods... NOW!
Forum rules
Can't get a mod to work?
Try these... FIRST!

http://www.davoonline.com/phpBB3/viewforum.php?f=6
Master Sergeant

Master Sergeant

Darhagonable
User avatar
Posts: 336
Joined: Mon Feb 23, 2015 9:37 am
Location: somewhere in the universe
Gender: Male
Zodiac: Capricorn
Contact:
Status: Offline

New Client & Broken Mods

Unread post #1 by Darhagonable » Wed Mar 22, 2017 8:40 am

Spore has been updated with a new client!
Info about the new client:
http://forum.spore.com/jforum/posts/list/86162.page

You can also visit this thread's Sporum counterpart here.

With the new client, some existing mods are no longer working as intended, if at all. I think it would be easier for everyone if we compiled a list of all the mods the new client broke, so they can all be identified and updated once a fix is found. So please post any mods you are having problems with and what the issue(s) with them are here.

Completely broken mods:
- Unlimited adventure complexity (Experimental fix available)
- Force Save (Experimental fix available)
- Davo's Vocal Bots
- Cell Parts in Creature Editor (standalone)
- Infinite SoL
- ToolMod
- All Badges
- Davo's Unlimited Complexity All Editors

Partially affected mods:
- Dark Injection (Compatibility update now available)
- Building Rotation (Results inconclusive)


Image
Image
Image
Image

Poster of the New User Apocalypse

Poster of the New User Apocalypse

foozle
Posts: 1
Joined: Wed Mar 22, 2017 8:14 pm
Gender: None specified
Status: Offline

Re: New Client & Broken Mods

Unread post #2 by foozle » Wed Mar 22, 2017 8:21 pm

I don't know if this is because of the new client, but the Dr. Pepper parts pack (just the .package, not from origin) is preventing creepy & cute parts to be accessed in the editor for me. That's with the origin version of spore, creepy & cute, and Galactic Adventures installed in that order.

EDIT: Nevermind, Origin was just installing the new version of Creepy & Cute
Last edited by foozle on Wed Mar 22, 2017 8:37 pm, edited 1 time in total.

Tech Support

Tech Support

rob55rod
User avatar
Posts: 3145
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.
Gender: Male
Status: Offline

Re: New Client & Broken Mods

Unread post #3 by rob55rod » Wed Mar 22, 2017 8:27 pm

foozle wrote:I don't know if this is because of the new client, but the Dr. Pepper parts pack (just the .package, not from origin) is preventing creepy & cute parts to be accessed in the editor for me. That's with the origin version of spore, creepy & cute, and Galactic Adventures installed in that order.

Actually they just haven't updated Creepy and Cute yet - it doesn't work either way.

Private

Private

Eevee Craft
User avatar
Posts: 34
Joined: Tue May 17, 2016 10:55 pm
Gender: Female
Zodiac: Sagittarius
Age: 15
Contact:
Status: Offline

Re: New Client & Broken Mods

Unread post #4 by Eevee Craft » Thu Mar 23, 2017 8:23 pm

Okay, I have another mod that's broken: the building symmetry mod. The symmetry in the building creator works, but screws over the adventure editor. When I attempt to edit one of my adventures with the mod installed, this message pops up: Image

For some reason, some buildings are remarked as having parts that aren't in the game (Despite me not even having any other building-related mods), and they're buildings I did not make myself, or don't even use the mod!
Screenshot of banned buildings:
With Mod: Image
Without Mod: (No error message appears) Image
Spore is your imagination, the stronger it is; the better you can be in Spore! Image

Private

Private

LilyValley
User avatar
Posts: 27
Joined: Sun Oct 02, 2016 12:37 pm
Gender: Female
Zodiac: Sagittarius
Contact:
Status: Offline

Re: New Client & Broken Mods

Unread post #5 by LilyValley » Sat Mar 25, 2017 10:43 am

I just redownloaded Spore due to the new client (and on a different pc) through Origin and now I tried to DL force save but it didn't work. After using the force save manual tweak I have started the game up, only to have it crash. I tried again, and in 15 minutes or so within starting it again, I encounter another crash. It's been only a few days since the client update, so I understand that there are things that need to be fixed/addressed, but I feel that crashing nearly instantly really needs to be reported.

Maybe it's because I added Himeric engine, which is new to my game or something up to date, or it may be that I didn't remove the force save package. Or the tweak regarding force save.. Either way, it's become near unplayable. I tried unmodded Core Spore last night without any complications. It's seemingly only after the manual tweak, so how would I try and find a solution?

Edit: I removed the force save mod but not the manual tweak. Still crashing almost instantly.
Image
Be sure to see my Spore videos on YouTube! You can find me under BetLV.

Sergeant

Sergeant

Snaid1
User avatar
Posts: 126
Joined: Tue Jul 27, 2010 10:52 am
Gender: None specified
Status: Offline

Re: New Client & Broken Mods

Unread post #6 by Snaid1 » Mon Mar 27, 2017 3:58 pm

I need to test in depth to check what else isn't working, but a mod not mentioned yet that's not working for me is the CB Spine Tweaker mod.

Edit Update:
I'm only going to include mods not listed in the first post:

mostly working:
Graveyard (no longer spawns bones around starting nest, otherwise works fine)
Forgotten Spore 2015 (causes other members of your species to disappear from home nest when starting creature stage, mate & members will reappear later)

Not Working:
CB Spine Tweaker

not sure which mod is causing it, but other creatures in the creature stage do not have a nest model even though it is fine on the map and the creatures all stay as if the nest was there.

will probably edit more later as I check other stages in detail.

Recruit

Recruit

Bhalandros
Posts: 7
Joined: Fri Jul 08, 2016 5:26 am
Gender: Male
Zodiac: Scorpio
Age: 16
Status: Offline

Re: New Client & Broken Mods

Unread post #7 by Bhalandros » Tue Mar 28, 2017 1:08 pm

Actually, my mods seem to work just fine. I was about to rant (and in fact I did, I just edited the message)
Dark injection is alright, and force save is too. I have a ton of mods so I wouldn't really know if something is screwed up.

Tech Support

Tech Support

rob55rod
User avatar
Posts: 3145
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.
Gender: Male
Status: Offline

Re: New Client & Broken Mods

Unread post #8 by rob55rod » Tue Mar 28, 2017 1:14 pm

Bhalandros wrote:Actually, my mods seem to work just fine. I was about to rant (and in fact I did, I just edited the message)
Dark injection is alright, and force save is too. I have a ton of mods so I wouldn't really know if something is screwed up.

Where did you install the game from? Origin, Steam, or GoG?

Recruit

Recruit

Bhalandros
Posts: 7
Joined: Fri Jul 08, 2016 5:26 am
Gender: Male
Zodiac: Scorpio
Age: 16
Status: Offline

Re: New Client & Broken Mods

Unread post #9 by Bhalandros » Tue Mar 28, 2017 1:19 pm

Steam version.

Tech Support

Tech Support

rob55rod
User avatar
Posts: 3145
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.
Gender: Male
Status: Offline

Re: New Client & Broken Mods

Unread post #10 by rob55rod » Tue Mar 28, 2017 3:01 pm

Bhalandros wrote:Steam version.

Do you have automatic updates enabled?

Recruit

Recruit

Bhalandros
Posts: 7
Joined: Fri Jul 08, 2016 5:26 am
Gender: Male
Zodiac: Scorpio
Age: 16
Status: Offline

Re: New Client & Broken Mods

Unread post #11 by Bhalandros » Wed Mar 29, 2017 10:42 am

Yep. It updated itself, I saw it update. I tried to stop it, but it was too quick. Sorry for the slow response, went away and haven't got access to a computer until right now.

EDIT: Steam was closed and I opened it, I saw the Spore thing in blue, and it said update. It updated.

Tech Support

Tech Support

rob55rod
User avatar
Posts: 3145
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.
Gender: Male
Status: Offline

Re: New Client & Broken Mods

Unread post #12 by rob55rod » Wed Mar 29, 2017 12:04 pm

Bhalandros wrote:Yep. It updated itself, I saw it update. I tried to stop it, but it was too quick. Sorry for the slow response, went away and haven't got access to a computer until right now.

EDIT: Steam was closed and I opened it, I saw the Spore thing in blue, and it said update. It updated.

I know this may sound like a strange request, but...


...can I get a list of all of the Dark Injection components you have installed and a screenshot of the creature editor in build mode with your current configuration?

Recruit

Recruit

Bhalandros
Posts: 7
Joined: Fri Jul 08, 2016 5:26 am
Gender: Male
Zodiac: Scorpio
Age: 16
Status: Offline

Re: New Client & Broken Mods

Unread post #13 by Bhalandros » Wed Mar 29, 2017 1:30 pm

Sure. Got a LOT of mods installed
DataEP1
dataEP1.PNG

Creature editor (I can save this, force save works) (although I just noticed I don't use the mod, as in the package, but the little fix in the configuration)
right here.PNG



AND JUST ANOTHER THING
I have always installed ALL mods in both Data AND DataEP1 (because reasons)
You could try that, who knows
You do not have the required permissions to view the files attached to this post.

Tech Support

Tech Support

rob55rod
User avatar
Posts: 3145
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.
Gender: Male
Status: Offline

Re: New Client & Broken Mods

Unread post #14 by rob55rod » Wed Mar 29, 2017 1:56 pm

Oh, you DO use the tweak. Okay, that suddenly is a lot less confusing...

...uh, can I ask another favor? I need another screenshot of the editor, this time with Dark Injection's UI-Darkspore and UI-!Layouts components installed. You don't have to keep them there, of course, I just need this for diagnostic purposes.

Recruit

Recruit

Bhalandros
Posts: 7
Joined: Fri Jul 08, 2016 5:26 am
Gender: Male
Zodiac: Scorpio
Age: 16
Status: Offline

Re: New Client & Broken Mods

Unread post #15 by Bhalandros » Wed Mar 29, 2017 2:04 pm

Here. (I erased the zip file, that's why I had to download again)
ignore the square.PNG

Ignore the square, it's a weird thing my pc does sometimes when dragging and dropping files
also the normal menu screen (the one with the galaxy) seemed very buggy, don't think it should be like this
trash.PNG
You do not have the required permissions to view the files attached to this post.
Last edited by Bhalandros on Wed Mar 29, 2017 2:32 pm, edited 1 time in total.

Tech Support

Tech Support

rob55rod
User avatar
Posts: 3145
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.
Gender: Male
Status: Offline

Re: New Client & Broken Mods

Unread post #16 by rob55rod » Wed Mar 29, 2017 2:23 pm

Bhalandros wrote:Downloading

What? They come in the ZIP with all the other DI components...

Recruit

Recruit

Bhalandros
Posts: 7
Joined: Fri Jul 08, 2016 5:26 am
Gender: Male
Zodiac: Scorpio
Age: 16
Status: Offline

Re: New Client & Broken Mods

Unread post #17 by Bhalandros » Wed Mar 29, 2017 2:38 pm

I erased the zip, doing a new message for notification purposes

Poster of the New User Apocalypse

Poster of the New User Apocalypse

Geshtro
Posts: 3
Joined: Sun Mar 05, 2017 1:33 pm
Gender: Female
Contact:
Status: Offline

Re: New Client & Broken Mods

Unread post #18 by Geshtro » Wed Mar 29, 2017 7:06 pm

Davo's Bot Vocal mod is broken, Cell parts in creature editor is broken.

The Grox expansion still works perfectly.

Your force save fix works perfectly. 11_Weaponpack mod works perfectly too. Testing Infinite SoL and toolMod now

Edit: Infinite SoL and toolMod is broken. The whole point of it as right after you get past the tutorial in space stage, every single tool is free and instantly available to get. Which, now it doesn't do whatsoever.

Another Edit. BetterSpore 1.5.1 is beyond broken now. Do not try to install any of it. GA breaks entirely and half the stuff doesn't work anymore.

Recruit

Recruit

Bhalandros
Posts: 7
Joined: Fri Jul 08, 2016 5:26 am
Gender: Male
Zodiac: Scorpio
Age: 16
Status: Offline

Re: New Client & Broken Mods

Unread post #19 by Bhalandros » Thu Mar 30, 2017 1:13 am

Cell parts in creature editor looks fine to me, at least the one that comes with DarkSpore.
BetterSpore 1.5.1 parts works fine, but any custom tools have disappeared from my save.
All badges mod does not work, and in fact, has reversed.
Extended solar systems seem to work fine.

With just the custom tool disappearance, this is ruined for me.
So... any way to go back to the old launcher?
Is the launcher just the .exe? I hope it is.

EDIT: Copying a supposedly "unupdated" (As in, everything except the new client). Will report back if it works

EDIT 2: It'll download eventually.

EDIT 3: Can't even open it. Probably because steam. If steam_api.dll is removed, an error jumps at me. Guess there's no going back. Well, thanks EA, I'll have to resort to playing in my other pc with internet off so steam won't update my stuff.

Poster of the New User Apocalypse

Poster of the New User Apocalypse

Barryplayz
Posts: 1
Joined: Thu Mar 30, 2017 11:38 am
Gender: None specified
Status: Offline

Re: New Client & Broken Mods

Unread post #20 by Barryplayz » Fri Mar 31, 2017 2:52 am

Seems like the Unlimited Complexity mod is completely broken.
You cant build unlimited like the mod was intended to.

But on if you install it on steam there seems to be no problems.


Return to “Mod Discussion”

Who is online

Users browsing this forum: No registered users and 2 guests