Spore R6025 Virtual Function error. Please help! [RESOLVED]

Forum rules

Remember that mods you download that are created by Davo REQUIRE Spore: Galactic Adventures and REQUIRE your game to be installed & patched in this order.

    - Install Spore Game

    - (OPTIONAL) Install Spore C&C

    - Install Spore Galactic Adventures

    - Patch Spore and Spore Galactic Adventures to 1.5.1

If you have any further questions, feel free to ask.
User avatar
Posts: 7
Joined: Sun Jan 01, 2017 4:53 pm

Spore R6025 Virtual Function error. Please help! [RESOLVED]

Unread postby Dark-Nite-Sunset » Sun Jan 01, 2017 4:57 pm

I have resolved this issue! I made a crazy gambit and decided to install the Creepy & Cute parts pack, and then Galactic Adventures.

Running spore with Galactic Adventures, through whatever reason, fixed the problem!


So.. I've seen plenty of topics all over the place, (not just here and such) about this error, but they never seem to have the same consensus of how to fix this nauseating error...

you see, I had Spore, It's expansions, and even DI installed on an external hard drive.. But earlier in 2016, the drive failed and I lost everything, including Spore.

Now, I have tried to reinstall the games, but.. Spore said it was already installed, so I had to 'uninstall' them.. When I had the (Frankly ugly) new version of Origin reinstall the first base game, Spore, it went fine, but.. when I try to start the game,

It gives me the infamous R6025 Pure Virtual Function Call error. I've tried reinstalling, no dice. I've moved both my game0 and game0.old folders away from Spore's appdata folder, nada. nothing seems to be working for a game that worked JUST FINE beforehand.

if it helps, I have Windows 8.1. Can anyone please help me fix this very irritating issue?

Return to “Help”