Dark Injections Several Problems.

For all those problems people post here that aren't actually related to Dark Injection. No hard feelings - I'd rather risk a few misdiagnosis than miss out on real Dark Injection issues someone wasn't 100% sure about.
Posts: 6
Joined: Sat Jul 08, 2017 8:32 pm

Dark Injections Several Problems.

Unread postby Jegarax0 » Sun Jul 09, 2017 9:47 am

Hello! I recently got back into spore after a few years and started by downloading the dark injection 9.r (BETA 2). I posted this same topic in the FAQ and help section as well, but i wanted to make sure i had not posted it in the wrong forum section so i post it here as well. Sorry if that is to any inconvenience.

I had the disc version and after downloading dark injections (and only one other mod, the infinite complexity and 100 points for adventures mod)
And it worked perfectly, for awhile. I really love the mod and made some creatures and adventures i am really proud and attached to.
The thing is that i decided to download spore on Origin, because i had the product keys for it, though the main reason was because i wanted to access the online functions, which apparently did not work on the disc version.

And once i Had installed spore from origin ( On another drive than the disc version) the problems started emerging. First thing i noticed was that the dark injection logo was not there even though I installed it the exact same way i had for the disc copy. The online functions worked properly, though everything related to dark injections was messed up. I could not play my adventures because it said that some (turns out almost every) of my creations had parts i did not have and would be replaced. In my sporepedia all my creations where there but they were not editable. But the weirdest part is that the parts are still usable in my creature editor, with the exception of that i could not save them. Another weird thing is that i can use my captain in who contain dark injection parts through space age adventures, but not through quick play. The other mod i mentioned does not seem to work either, though i find that less important.

So here i am with almost 100 creatures in my sporepedia that i cant use in any way, i cant create new ones if they contain any mod parts. I have lost all functionality of the adventures I spent hundreds of hours creating.

I'm not a novice when it comes to modding and such but im far from a professional either. The things i have tried is:
1. Copy the data directories from the folders belonging to the disc versions. (I always backup my files so i restored it when that didnt work)
2. Deleted the mod(s) and reinstalled it.
3. Started core spore and let it synchronize and then start galactic adventures again to do the same (as suggested in some thread i read)

I would very much appreciate any help i can get. Thanks in advance.

Return to “Misdiagnosis”