“Dark-style” UI issues.

Found a bug in a 9.r beta? Let us know here, so we can fix it.
Forum rules
1. Please post only ONE bug per THREAD. If you have multiple bugs to report, create a thread FOR EACH BUG.

2. Please NAME your THREADS as DESCRIPTIVELY as possible.

3. Please DO NOT CREATE report threads for bugs which have already been reported. This produces REDUNDANT BUG REPORTS, which slows down development by making it harder for me to read, reports and fix the bugs mentioned within them. This also applies for bugs which have been fixed and moved accordingly, so CHECK the FIXED BUGS subforum BEFORE POSTING. Previously-submitted bug reports can be found here: viewforum.php?f=174
TepigNinja
Recruit
Recruit
Posts: 5
Joined: Wed Mar 11, 2020 3:04 pm

“Dark-style” UI issues.

Unread postby TepigNinja » Wed Mar 11, 2020 6:06 pm

Just downloaded the mod from the Dark Injection site today, really love what it brings so far! However I’ve found some issues with the Dark-style only UI, specifically the “Submit feedback” button obstructing the camera control buttons among other things. I know you can use the mouse to control it, but it’s still needless to say kinda annoying. Another thing I noticed that the creature abilities are misaligned somewhat, though I’m not sure if that was intended or not, but I think it should be within the box? Forgive me for the poor image quality, I had to take these with my phone. Could this possibly be a problem with the way my computer displays things? Any help at all would be appreciated, thanks in advance! :D

rob55rod
Tech Support
Tech Support
Sergeant Major of the Davo Army
Sergeant Major of the Davo Army
Posts: 3983
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.

Re: “Dark-style” UI issues.

Unread postby rob55rod » Thu Mar 12, 2020 2:59 pm

Thanks for the heads-up...though it looks like the images you mentioned didn't end up being attached to your post.

If it's any use, on whatever you're computer you're playing Spore on, you can press the "C" key while Spore is active to take a screenshot of the game. You may or may not need to enter the "togglecaptureui" cheat beforehand in order for the screenshots to show the GUI. The screenshots will be saved to the "Pictures" folder in your "My Spore Creations" folder, just like if you'd taken them using the screenshot button in test drive mode. (Note that these folder names will be different if you're playing in a non-English language)
Having trouble with the Spore ModAPI Launcher Kit? Get help here!

If you're reading this, you have my permission to build off of my mods as long as I am credited. Please don't mirror my work unaltered, unless I no longer provide a working download.

TepigNinja
Recruit
Recruit
Posts: 5
Joined: Wed Mar 11, 2020 3:04 pm

Re: “Dark-style” UI issues.

Unread postby TepigNinja » Sat Mar 14, 2020 11:20 am

Hello again! Sorry about the late reply, and thank you for telling me how to take a proper screenshot, honestly forgot all I had to do was Press C, haha. However despite that, and turning the togglecaptureui command on and off, the picture refused to show the UI. So this time I emailed the pictures and am uploading them here through my computer. Hopefully this time it works! I noticed some other issues i'f like to point out too if thats okay. Hope you have a fantastic day!

TepigNinja
Recruit
Recruit
Posts: 5
Joined: Wed Mar 11, 2020 3:04 pm

Re: “Dark-style” UI issues.

Unread postby TepigNinja » Sat Mar 14, 2020 1:31 pm

Okay it doesn’t look like they went through again... sigh. Sorry about that, don’t know what went wrong. If they actually didn’t, ill describe my problems.


Issue 1: “Submit di feedback” button obstructs the camera control buttons in all editors (except adventure) and test drive.


Issue 2: The tags for Abilities, Attack, and Social skills for a creature seem to be off center from that box in the creature and adventure editors, along with the sporepedia.


Issue 3: when hovering the mouse cursor over the creature creator icon in the Creator select menu, a white box appears behind the circular icon of the creature.


Issue 4: The name box somewhat obstructs some of the action buttons in the test drive mode, though the buttons can still be clicked.


Anyways sorry the images won’t upload, and sorry if it seems like I’m nitpicking. Don’t know why the images won’t load. Anyways thanks for putting up with all this, and have a great day!

TepigNinja
Recruit
Recruit
Posts: 5
Joined: Wed Mar 11, 2020 3:04 pm

Re: “Dark-style” UI issues.

Unread postby TepigNinja » Sat Mar 14, 2020 2:43 pm

Okay quick Follow-up. I did some testing with the game's screen size setting and that solved the problem with the feedback button getting in the of the camera controls buttons, I upped the screen size to the largest setting, and it was no longer in the way, that was honestly my biggest concern. However since my computer is not very powerful, the max screen-size slows down performance considerably, so I need to keep it down in order to maintain good performance. Perhaps moving the feedback option to the Options menu if possible? I'll also suggest this the feedback section as well. Thank you!


Return to “DI 9.r Bug Reports”