Dark Injections saying I'm not using modAPI when I am?

Found a bug in a 9.r beta? Let us know here, so we can fix it.
Forum rules
1. Please post only ONE bug per THREAD. If you have multiple bugs to report, create a thread FOR EACH BUG.

2. Please NAME your THREADS as DESCRIPTIVELY as possible.

3. Please DO NOT CREATE report threads for bugs which have already been reported. This produces REDUNDANT BUG REPORTS, which slows down development by making it harder for me to read, reports and fix the bugs mentioned within them. This also applies for bugs which have been fixed and moved accordingly, so CHECK the FIXED BUGS subforum BEFORE POSTING. Previously-submitted bug reports can be found here: viewforum.php?f=174
Recruit

Recruit

Maximilian Mori
Posts: 6
Joined: Thu Jan 10, 2019 7:29 am

Dark Injections saying I'm not using modAPI when I am?

Unread postby Maximilian Mori » Thu Jan 10, 2019 7:38 am

I'm not sure how to fix this. I just patched dark injection into my copy of GA from steam, but everytime I use the mod API to try and open it, the spore mod API launcher fails and GA runs only to say I have to use mod API launcher. I keep trying to find anything to fix this since I just modded the game traditionally by unzipping the mods and putting them in, but nothing works. Did I download the mod wrong? I have :cc: :ex: :ga: :patch1.5: :spore: but :di: won't work.... I've downloaded it before and had nearly no problems on another computer, but this is my first time with a big issue.

Corporal

Corporal

VanillaCold
User avatar
Posts: 75
Joined: Fri Nov 02, 2018 2:36 pm
Contact:

Re: Dark Injections saying I'm not using modAPI when I am?

Unread postby VanillaCold » Thu Jan 10, 2019 10:19 am

Maximilian Mori wrote:I keep trying to find anything to fix this since I just modded the game traditionally by unzipping the mods and putting them in, but nothing works.

Try using the ModAPI easy installer instead of installing DI manually. (it's ment to be installed via the easy installer)
Creator of Solar Spore and Spaceplanes.

My main account broke a while ago, which is why I created this alt.

Recruit

Recruit

Maximilian Mori
Posts: 6
Joined: Thu Jan 10, 2019 7:29 am

Re: Dark Injections saying I'm not using modAPI when I am?

Unread postby Maximilian Mori » Fri Jan 11, 2019 9:39 am

VanillaCold wrote:
Maximilian Mori wrote:I keep trying to find anything to fix this since I just modded the game traditionally by unzipping the mods and putting them in, but nothing works.

Try using the ModAPI easy installer instead of installing DI manually. (it's ment to be installed via the easy installer)



I can't, the only version that would download for me was the old version of modAPI, and the other version (when I would try to install it) Would start download, freeze, and then crash.. the old version won't allow me to install the mod. I've tried many times, but it won't work. I had to take the mod out entirely just so I could get past the thing saying that I wasn't using the modAPI. Now I'm just using GA without my favorite mod.

Poster of the New User Apocalypse

Poster of the New User Apocalypse

oliiwiaq
User avatar
Posts: 1
Joined: Fri Jan 11, 2019 11:02 am

Re: Dark Injections saying I'm not using modAPI when I am?

Unread postby oliiwiaq » Fri Jan 11, 2019 11:04 am

Same here. I have everything for the mod but it's just not working.

Tech Support

Tech Support

rob55rod
User avatar
Posts: 3513
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.

Re: Dark Injections saying I'm not using modAPI when I am?

Unread postby rob55rod » Fri Jan 11, 2019 8:26 pm

Both of you, download a fresh copy of the ModAPI Launcher Kit's setup program. I updated it the other day, which...should resolve the crashes during installation.

Recruit

Recruit

Maximilian Mori
Posts: 6
Joined: Thu Jan 10, 2019 7:29 am

Re: Dark Injections saying I'm not using modAPI when I am?

Unread postby Maximilian Mori » Fri Jan 11, 2019 10:12 pm

rob55rod wrote:Both of you, download a fresh copy of the ModAPI Launcher Kit's setup program. I updated it the other day, which...should resolve the crashes during installation.


Thank you, I was finally able to download the spore modAPI launcher kit- now the only problem is that the mod API launcher still isn't launching my version of GA. It's just coming up with an error everytime. Here is a screenshot of what it says- Image

It's basically the same things that were happening before with the older version (aside from it letting me use the installer and uninstaller now), except now GA doesn't even register the mods I tried installing through the spore modAPI easy installer.

Tech Support

Tech Support

rob55rod
User avatar
Posts: 3513
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.

Re: Dark Injections saying I'm not using modAPI when I am?

Unread postby rob55rod » Sat Jan 12, 2019 5:44 am

Do you have any kind of antiv--
>AVG icon on Desktop
Add an exception for both GA's executable (or the folder it's in) and the ModAPI Launcher Kit folder. Let me know if that helps.

Recruit

Recruit

Maximilian Mori
Posts: 6
Joined: Thu Jan 10, 2019 7:29 am

Re: Dark Injections saying I'm not using modAPI when I am?

Unread postby Maximilian Mori » Sat Jan 12, 2019 12:43 pm

Image

I should note that even though the game doesn't run through the modAPI, it comes up with that error and then automatically opens from steam, and plays as the normal GA game. I didn't know if I made that clear before, so I'm sorry about that.

I made the exeptions there, and at one point even turned off the antivirus completely. It still does this. I've also tried installing a fresh version of DI, but that still doesn't work...

Tech Support

Tech Support

rob55rod
User avatar
Posts: 3513
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.

Re: Dark Injections saying I'm not using modAPI when I am?

Unread postby rob55rod » Sat Jan 12, 2019 1:00 pm

Maximilian Mori wrote:Image

...okay, there goes that idea.

Maximilian Mori wrote:I should note that even though the game doesn't run through the modAPI, it comes up with that error and then automatically opens from steam, and plays as the normal GA game. I didn't know if I made that clear before, so I'm sorry about that.

Actually, the ModAPI Launcher starts Spore through Steam if it is installed through Steam, as the Steam version (atleast in some cases?) can't be started normally. The issue here is that while starting the game works as intended, something goes wrong while injecting your ModAPI mods' code into the game process. Unfortunately, we've yet to find a clean way to detect that something has gone wrong and stop the game from opening.

Maximilian Mori wrote:I made the exeptions there, and at one point even turned off the antivirus completely. It still does this. I've also tried installing a fresh version of DI, but that still doesn't work...

That's worked for some, but there are other factors which can also contribute to this issue. Do you use Discord, by any chance? (or, failing that, Steam or Skype?) It would be easier to resolve this issue using a more immediate form of communication, if you're willing and able.




Also, for anyone else reading this thread, I'd like to clarify that this issue is not caused by Dark Injection, but by one or more of a variety of imperfections in the ModAPI Launcher. The process of resolving these issues is ongoing.

Recruit

Recruit

Maximilian Mori
Posts: 6
Joined: Thu Jan 10, 2019 7:29 am

Re: Dark Injections saying I'm not using modAPI when I am?

Unread postby Maximilian Mori » Sat Jan 12, 2019 1:05 pm

ah, that makes sense. Also yes, I do use discord.

and I'm sorry about posting this here, I thought it was a problem with DI in the beginning ^^; My apologies-

Tech Support

Tech Support

rob55rod
User avatar
Posts: 3513
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.

Re: Dark Injections saying I'm not using modAPI when I am?

Unread postby rob55rod » Sat Jan 12, 2019 1:29 pm

Maximilian Mori wrote:ah, that makes sense. Also yes, I do use discord.

Perfect. What name and Discord tag can I find you under, if you don't mind sharing? (If you'd rather PM it my way or you'd rather I provide my Discord tag, that's fine, just let me know)

Maximilian Mori wrote:and I'm sorry about posting this here, I thought it was a problem with DI in the beginning ^^; My apologies-

No it's fine...it isn't exactly obvious as to where the cause lies. I just mentioned that clarification as a "for future reference" thing, to clarify to anyone reading this going forward.

Recruit

Recruit

Maximilian Mori
Posts: 6
Joined: Thu Jan 10, 2019 7:29 am

Re: Dark Injections saying I'm not using modAPI when I am?

Unread postby Maximilian Mori » Sat Jan 12, 2019 2:36 pm

Max the dirty memer#7163

ah, alright ^^

Poster of the New User Apocalypse

Poster of the New User Apocalypse

StarDragon984237
Posts: 2
Joined: Thu Jan 10, 2019 6:17 am

Re: Dark Injections saying I'm not using modAPI when I am?

Unread postby StarDragon984237 » Sat Jan 12, 2019 4:22 pm

If the problem is solved, please share the information on how you did it, if possible.
I think I have the same problem..


Return to “DI 9.r Bug Reports”

Who is online

Users browsing this forum: No registered users and 2 guests

cron