Transferred Creations are Missing Parts

Found a bug in a 9.r beta? Let us know here, so we can fix it.
Forum rules
1. Please post only ONE bug per THREAD. If you have multiple bugs to report, create a thread FOR EACH BUG.

2. Please NAME your THREADS as DESCRIPTIVELY as possible.

3. Please DO NOT CREATE report threads for bugs which have already been reported. This produces REDUNDANT BUG REPORTS, which slows down development by making it harder for me to read, reports and fix the bugs mentioned within them. This also applies for bugs which have been fixed and moved accordingly, so CHECK the FIXED BUGS subforum BEFORE POSTING. Previously-submitted bug reports can be found here: viewforum.php?f=174
Shiznasty
Recruit
Recruit
Posts: 5
Joined: Mon Sep 03, 2018 10:18 am

Transferred Creations are Missing Parts

Unread postby Shiznasty » Fri Jan 04, 2019 2:24 am

Transferred creations from an older version of 9.r to the newest across creations and got met with these beauties.

Spoiler: show
Image
Image
Image
Image
Image
Image
Image
Image
Image

There's many, many more examples of this I could list in the images but I'm too lazy. Here's the originals, in the same order.
Spoiler: show
Image
Image
Image
Image
Image
Image
Image
Image


The main theme here is that all the DI parts have turned invisible and glitched; mouth parts have sometimes been replaced; and hands, feet, and sometimes even mouths have been sent all over the place where they're not supposed to be, replacing certain DI and vanilla parts entirely - the arzet/bottom picture had the belly button replaced and suitable resized by his hand.

I need a fix so I know that my past 2 and a half years of work haven't gone down the drain.
Please and thank you.
Last edited by Shiznasty on Fri Jan 04, 2019 2:26 am, edited 1 time in total.

Shiznasty
Recruit
Recruit
Posts: 5
Joined: Mon Sep 03, 2018 10:18 am

Re: Transferring creations

Unread postby Shiznasty » Fri Jan 04, 2019 2:25 am

Yes, I know that my pictures are low quality.
Print screen and C does not work on Spore's sporepedia menu, so I had to take pictures with an iPad.

User avatar
rob55rod
Tech Support
Tech Support
Sergeant Major of the Davo Army
Sergeant Major of the Davo Army
Posts: 3632
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.

Re: Transferred Creations are Missing Parts

Unread postby rob55rod » Fri Jan 04, 2019 6:18 am

I assure you that this is definitely fixable. Ironically, however, viewing a ton of creations was just about the worst thing to do in this situation, as the fix doesn't immediately work retroactively. It takes time - time spent ONLY viewing OTHER creations. This is not a product of Dark Injection, and is in fact caused by how Spore caches baked creation models. We can try clearing your GraphicsCache after the issue is resolved to force the game to regenerate the models, but given how unreliable the game is about these kinds of things, I can't guarantee that it will be able to generate a new cache at all.

Anywaves, currently awaiting a response on Discord.


Return to “DI 9.r Bug Reports”