Crashes when opening creature creator

Found a bug in a 9.r beta? Let us know here, so we can fix it.
Forum rules
1. Please post only ONE bug per THREAD. If you have multiple bugs to report, create a thread FOR EACH BUG.

2. Please NAME your THREADS as DESCRIPTIVELY as possible.

3. Please DO NOT CREATE report threads for bugs which have already been reported. This produces REDUNDANT BUG REPORTS, which slows down development by making it harder for me to read, reports and fix the bugs mentioned within them. This also applies for bugs which have been fixed and moved accordingly, so CHECK the FIXED BUGS subforum BEFORE POSTING. Previously-submitted bug reports can be found here: viewforum.php?f=174
Poster of the New User Apocalypse

Poster of the New User Apocalypse

scrgp9512
User avatar
Posts: 2
Joined: Tue Jan 01, 2019 12:05 am

Crashes when opening creature creator

Unread postby scrgp9512 » Tue Jan 01, 2019 12:09 am

So I'm using Dark Injections for the first time here. I installed it and booted the API launcher and the game launches just fine. However when I go to open the creature creator it never opens, the game crashes and closes before it can do so. I couldn't really find anything here about this already so here's this post. I am using the Steam version and I have GA and C&C with the asymmetry patch.

Recruit

Recruit

Marduk
User avatar
Posts: 8
Joined: Sun Dec 23, 2018 4:22 pm
Location: California, U.S.A.

Re: Crashes when opening creature creator

Unread postby Marduk » Tue Jan 01, 2019 12:13 pm

scrgp9512 wrote:So I'm using Dark Injections for the first time here. I installed it and booted the API launcher and the game launches just fine. However when I go to open the creature creator it never opens, the game crashes and closes before it can do so. I couldn't really find anything here about this already so here's this post. I am using the Steam version and I have GA and C&C with the asymmetry patch.


Some mods doesn't works with steam version, btw, there's a way to change steam version to origin version, i dunno how, but there was a video on Youtube, i'll try to find it and by the way, what's the installation path? where u installed the mod?
DATA CENTER
Race: Anunnaki

Captain's name: Marduk

Homeworld: Nibiru

Archetype: Warrior

Status: Alive

Location : Planet Zeal,In The Second Galactic Arm. / In Pegassi - A's System

MISSION :

Steal The Enemy's Technology

Corporal

Corporal

VanillaCold
User avatar
Posts: 75
Joined: Fri Nov 02, 2018 2:36 pm
Contact:

Re: Crashes when opening creature creator

Unread postby VanillaCold » Tue Jan 01, 2019 2:20 pm

Marduk wrote:Some mods doesn't works with steam version, btw, there's a way to change steam version to origin version, i dunno how, but there was a video on Youtube, i'll try to find it and by the way, what's the installation path? where u installed the mod?

All mods which were made for Patch 1.7 work with the Steam version.
Patch 1.7 turns the Origin version into the Steam version, which is why older mods don't work with the latest version.
DI works fine for me, even though I'm using the Steam version.

Anyway, you should try these first:
1: Verify your game files. This will make Steam check for errors within Spore's files. If it finds any corrupt/missing files, it'll redownload them. (this doesn't apply to mods)
2: Uninstall all mods excluding DI and slowly add them back to Spore until you find what's causing the problem.
Creator of Solar Spore and Spaceplanes.

My main account broke a while ago, which is why I created this alt.

Tech Support

Tech Support

rob55rod
User avatar
Posts: 3513
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.

Re: Crashes when opening creature creator

Unread postby rob55rod » Tue Jan 01, 2019 7:54 pm

scrgp9512 wrote:So I'm using Dark Injections for the first time here. I installed it and booted the API launcher and the game launches just fine. However when I go to open the creature creator it never opens, the game crashes and closes before it can do so. I couldn't really find anything here about this already so here's this post. I am using the Steam version and I have GA and C&C with the asymmetry patch.

Hmmm...mind showing me your current DI configuration? (sorry about the confusion above btw)

Poster of the New User Apocalypse

Poster of the New User Apocalypse

scrgp9512
User avatar
Posts: 2
Joined: Tue Jan 01, 2019 12:05 am

Re: Crashes when opening creature creator

Unread postby scrgp9512 » Tue Jan 01, 2019 8:04 pm

rob55rod wrote:
scrgp9512 wrote:So I'm using Dark Injections for the first time here. I installed it and booted the API launcher and the game launches just fine. However when I go to open the creature creator it never opens, the game crashes and closes before it can do so. I couldn't really find anything here about this already so here's this post. I am using the Steam version and I have GA and C&C with the asymmetry patch.

Hmmm...mind showing me your current DI configuration? (sorry about the confusion above btw)


This was the only thing I changed Image

Everything else is default

Also to the post above, core Spore, C&C, and GA all are validated and the game runs fine without DI installed (it's the only mod I have/had)

Tech Support

Tech Support

rob55rod
User avatar
Posts: 3513
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.

Re: Crashes when opening creature creator

Unread postby rob55rod » Wed Jan 02, 2019 7:20 pm

scrgp9512 wrote:
rob55rod wrote:
scrgp9512 wrote:So I'm using Dark Injections for the first time here. I installed it and booted the API launcher and the game launches just fine. However when I go to open the creature creator it never opens, the game crashes and closes before it can do so. I couldn't really find anything here about this already so here's this post. I am using the Steam version and I have GA and C&C with the asymmetry patch.

Hmmm...mind showing me your current DI configuration? (sorry about the confusion above btw)


This was the only thing I changed Image

Everything else is default

Also to the post above, core Spore, C&C, and GA all are validated and the game runs fine without DI installed (it's the only mod I have/had)

I think I may know what's going on there. I'll be releasing a bugfix update within the near future. Once that's out, let me know if installing it resolves this issue.


Return to “DI 9.r Bug Reports”

Who is online

Users browsing this forum: No registered users and 1 guest