Bugged Spore core Mouths

Found a bug in a 9.r beta? Let us know here, so we can fix it.
Forum rules
1. Please post only ONE bug per THREAD. If you have multiple bugs to report, create a thread FOR EACH BUG.

2. Please NAME your THREADS as DESCRIPTIVELY as possible.

3. Please DO NOT CREATE report threads for bugs which have already been reported. This produces REDUNDANT BUG REPORTS, which slows down development by making it harder for me to read, reports and fix the bugs mentioned within them. This also applies for bugs which have been fixed and moved accordingly, so CHECK the FIXED BUGS subforum BEFORE POSTING. Previously-submitted bug reports can be found here: viewforum.php?f=174
Poster of the New User Apocalypse

Poster of the New User Apocalypse

THEWEATLEY
Posts: 1
Joined: Tue Jan 16, 2018 2:07 pm
Gender: None specified
Status: Offline

Bugged Spore core Mouths

Unread post #1 by THEWEATLEY » Tue Jan 16, 2018 8:09 pm

The bug started to appear in the start of the creature stage, it caused the mouths that i tried to place on the creature to kind of bug below and behind of it, down there the mouths could not be taked and "selled" like any normal part so they were stuck there forever as i already said the bug started in teh creature stage and now that i am already past half of the stage the bug is still there, if you know any way to solve this problem the help is appreciated Thanks :)



Tech Support

Tech Support

rob55rod
User avatar
Posts: 3324
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.
Gender: Male
Status: Offline

Re: Bugged Spore core Mouths

Unread post #2 by rob55rod » Wed Jan 17, 2018 9:04 am

Can you show a screenshot of the problem? I'm having a hard time determining what the problem is based on words alone.

Recruit

Recruit

Olivvyia
User avatar
Posts: 7
Joined: Sun Jan 21, 2018 4:26 pm
Gender: Female
Zodiac: Scorpio
Age: 19
Status: Offline

Re: Bugged Spore core Mouths

Unread post #3 by Olivvyia » Mon Jan 22, 2018 1:24 pm

I'm actually having a similar problem. Whenever I attempt to use a DI head, it doesn't drag onto the creature but instead appears invisible until I mouse over it. I have the arena files installed (tried both versions) and my game is patched (Origin). I'll attach some screenshots to show you what I mean.

spore2.png
spore1.png


I'm also having a problem where whenever I use a core Spore part (such as the mouth), my game freezes and I have to force close it with task manager.

Any help is very much appreciated! If you need anymore information, just let me know. Thanks!
You do not have the required permissions to view the files attached to this post.

Tech Support

Tech Support

rob55rod
User avatar
Posts: 3324
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.
Gender: Male
Status: Offline

Re: Bugged Spore core Mouths

Unread post #4 by rob55rod » Mon Jan 22, 2018 6:27 pm

Olivvyia wrote:Any help is very much appreciated! If you need anymore information, just let me know. Thanks!

Okay that's really weird...mind providing screenshots of your Core Spore and Galactic Adventures Data folders? (If you don't know where those are, go here: viewtopic.php?f=26&t=6010 )

Recruit

Recruit

Olivvyia
User avatar
Posts: 7
Joined: Sun Jan 21, 2018 4:26 pm
Gender: Female
Zodiac: Scorpio
Age: 19
Status: Offline

Re: Bugged Spore core Mouths

Unread post #5 by Olivvyia » Mon Jan 22, 2018 9:46 pm

Not at all! Here you go:
SPORE4.png

SPORE3.png

I have a feeling it may be my fault. Either I placed something where it doesn't belong or something else. I'm not entirely sure.
You do not have the required permissions to view the files attached to this post.

Tech Support

Tech Support

rob55rod
User avatar
Posts: 3324
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.
Gender: Male
Status: Offline

Re: Bugged Spore core Mouths

Unread post #6 by rob55rod » Tue Jan 23, 2018 6:59 am

Olivvyia wrote:I have a feeling it may be my fault. Either I placed something where it doesn't belong or something else. I'm not entirely sure.

Seems you're correct - you didn't install the mod, you just dumped the installer into your GA Data folder. Don't do that, lol

You'll need to use the Spore ModAPI Easy Installer to install it. In fact, you can install almost any mod with it.

Recruit

Recruit

Olivvyia
User avatar
Posts: 7
Joined: Sun Jan 21, 2018 4:26 pm
Gender: Female
Zodiac: Scorpio
Age: 19
Status: Offline

Re: Bugged Spore core Mouths

Unread post #7 by Olivvyia » Tue Jan 23, 2018 2:59 pm

Wow, I feel dumb lol. It's not like this is my first time installing mods either. x.x

But thank you so much for your help. I really appreciate the quick responses. You're the perfect kind of person for tech support. (:

EDIT: It works perfectly now. Thank you so so much~!

EDIT 2: Apparently I spoke too soon. I'm still having the same issue as before but it's with every mouth, not just the DI mouths. Here's some screenshots:
spore5.png

spore6.png

spore7.png

spore8.png

Also, here's what my folder looks like:
spore9.png

spore10.png


One more thing too. Is there a way to increase the size of the UI? It's a little small for my tastes.
You do not have the required permissions to view the files attached to this post.

Tech Support

Tech Support

rob55rod
User avatar
Posts: 3324
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.
Gender: Male
Status: Offline

Re: Bugged Spore core Mouths

Unread post #8 by rob55rod » Tue Jan 23, 2018 6:31 pm

Olivvyia wrote:Wow, I feel dumb lol. It's not like this is my first time installing mods either. x.x

Eh, I've seen plenty worse. Don't worry about it, just read the instructions next time.

Olivvyia wrote:But thank you so much for your help. I really appreciate the quick responses. You're the perfect kind of person for tech support. (:

Np :mrgreen:

Olivvyia wrote:It works perfectly now. Thank you so so much~!

Great to hear the probl-

Olivvyia wrote:Apparently I spoke too soon. I'm still having the same issue as before but it's with every mouth, not just the DI mouths.

...oh, well that's...odd.

My next guess would have to be 2012_DI_v8a_UltimateCellEditorSupport.package . See if getting rid of that helps. I designed the DI Installer to automatically remove previous versions of Dark Injection to prevent issues such as this one, but evidently the current implementation is...flawed. Ah well, I'll have that much fixed for the next Public Beta.

Olivvyia wrote:One more thing too. Is there a way to increase the size of the UI? It's a little small for my tastes.

Just pick a different UI. You can easily do so by running the ModAPI Easy Uninstaller (again, as Administrator), and then clicking the Gear icon beside the entry for Dark Injection 9.r . This will open the Dark Injection Configurator, which can perform the previously-mentioned reconfiguration as well as uninstall the mod completely, should you choose.

Although, I've heard a lot of people say that if you can make the transition, the smaller UI leaves more space for your creation...eh, just food for thought ._____.

Recruit

Recruit

Olivvyia
User avatar
Posts: 7
Joined: Sun Jan 21, 2018 4:26 pm
Gender: Female
Zodiac: Scorpio
Age: 19
Status: Offline

Re: Bugged Spore core Mouths

Unread post #9 by Olivvyia » Tue Jan 23, 2018 6:37 pm

You're awesome. I will touch base on whether or not that worked once I get back to my PC. Thank you so much for everything!

EDIT: Unfortunately, deleting 2012_DI_v8a_UltimateCellEditorSupport.package did not solve my problem. For now, I think I'm just going to play without Dark Injection(sadly) and see if that fixes my issue.

EDIT 2: Ugh. So, it's not actually Dark Injection. Guess it's time to delete all of my mods and install them one at a time.

EDIT 3: OKAY. So, I uninstalled Dark Injection and then reinstalled each mod one at a time and started Spore. I went into the creature creator and tried to place a head on the body. All was fine until I installed Davo's Unlimited Complexity For All Editors mod. That caused the head to turn invisible and go to the floor as before. So, I pitched that and continued. The next issue I ran into was with Davo's Creature Cells. That mod caused my game to freeze everytime I placed any sort of head on the body. I deleted both of them and Spore runs just fine. Next, I need to see if Dark Injection will work with my mods. I will update you once I'm through with that.

EDIT 1552: Dark Injection works in creature creator, now I just to see if it works in the campaign.

EDIT 3589: Well, everything was going fine until I tried to evolve from cell to early creature stage. :I Guess it's back to uninstalling mods.

EDIT 6978: Okay. I'm stuck again. I go through cell stage and when I try to evolve from cell to early creature stage, I get stuck on a white screen. It's not frozen--I can still move my cursor. But it never loads.

Tech Support

Tech Support

rob55rod
User avatar
Posts: 3324
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.
Gender: Male
Status: Offline

Re: Bugged Spore core Mouths

Unread post #10 by rob55rod » Wed Jan 24, 2018 5:49 am

Olivvyia wrote:You're awesome. I will touch base on whether or not that worked once I get back to my PC. Thank you so much for everything!

^-^

Olivvyia wrote:EDIT: Unfortunately, deleting 2012_DI_v8a_UltimateCellEditorSupport.package did not solve my problem. For now, I think I'm just going to play without Dark Injection(sadly) and see if that fixes my issue.

Well if it's any reassurance, it's bound to prevent other problems from coming up.

Olivvyia wrote:EDIT 2: Ugh. So, it's not actually Dark Injection. Guess it's time to delete all of my mods and install them one at a time.

Some people would've given up at that point. Good on you for not doing so.

Olivvyia wrote:EDIT 3: OKAY. So, I uninstalled Dark Injection and then reinstalled each mod one at a time and started Spore. I went into the creature creator and tried to place a head on the body. All was fine until I installed Davo's Unlimited Complexity For All Editors mod. That caused the head to turn invisible and go to the floor as before. So, I pitched that and continued.

Well luckily for you, Dark Injection includes an arguably superior version of the same feature as of Public Beta 2.1.6 :lol:

Olivvyia wrote:The next issue I ran into was with Davo's Creature Cells. That mod caused my game to freeze everytime I placed any sort of head on the body. I deleted both of them and Spore runs just fine. Next, I need to see if Dark Injection will work with my mods. I will update you once I'm through with that.

EDIT 1552: Dark Injection works in creature creator, now I just to see if it works in the campaign.

EDIT 3589: Well, everything was going fine until I tried to evolve from cell to early creature stage. :I Guess it's back to uninstalling mods.

EDIT 6978: Okay. I'm stuck again. I go through cell stage and when I try to evolve from cell to early creature stage, I get stuck on a white screen. It's not frozen--I can still move my cursor. But it never loads.

Looking the remaining mods, I've identified a couple of possible culprits:

Code: Select all

LP-DavoCreatureOverhaulV1.package
LP-DavosLiquidCell.package


and, less likely, these:

Code: Select all

LP-CheapCellPartsTsundaMod.package
LP-TrueEpicPlay.package


Let me know if getting rid of any of those works. Also note that you may want to test on a different planet each time, to avoid biasing the outcome.

Recruit

Recruit

Olivvyia
User avatar
Posts: 7
Joined: Sun Jan 21, 2018 4:26 pm
Gender: Female
Zodiac: Scorpio
Age: 19
Status: Offline

Re: Bugged Spore core Mouths

Unread post #11 by Olivvyia » Wed Jan 24, 2018 11:59 pm

Oh my god, you're a life saver. I got rid of all of the aforementioned mods and voila! Works like a charm. Now my Spore is pretty much just Dark Injection and core but it's so much better than just vanilla. Thank you so much for all of your help!

Tech Support

Tech Support

rob55rod
User avatar
Posts: 3324
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.
Gender: Male
Status: Offline

Re: Bugged Spore core Mouths

Unread post #12 by rob55rod » Thu Jan 25, 2018 6:30 am

Olivvyia wrote:Oh my god, you're a life saver. I got rid of all of the aforementioned mods and voila! Works like a charm. Now my Spore is pretty much just Dark Injection and core but it's so much better than just vanilla. Thank you so much for all of your help!

No problem, glad to see the problem is solved, and that you're enjoying the mod.

Just wondering...do you know which of those last few mods caused the problem, specifically? (Just wondering for future reference, in case someone else comes across this problem)

Recruit

Recruit

Olivvyia
User avatar
Posts: 7
Joined: Sun Jan 21, 2018 4:26 pm
Gender: Female
Zodiac: Scorpio
Age: 19
Status: Offline

Re: Bugged Spore core Mouths

Unread post #13 by Olivvyia » Thu Jan 25, 2018 1:51 pm

All of them actually caused an issue. As well as a building rotation mod I had installed. That one caused the head issue with buildings and doors.

Tech Support

Tech Support

rob55rod
User avatar
Posts: 3324
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.
Gender: Male
Status: Offline

Re: Bugged Spore core Mouths

Unread post #14 by rob55rod » Thu Jan 25, 2018 2:53 pm

Olivvyia wrote:All of them actually caused an issue. As well as a building rotation mod I had installed. That one caused the head issue with buildings and doors.

Well that's...odd. Guess I'll have to see what's up with those mods, then. Thanks, and glad to see the problem is solved.


Return to “DI 9.r Bug Reports”

Who is online

Users browsing this forum: No registered users and 1 guest