Camera/Mouse bug in creators with full DI GUI

Squashed beyond recognition. Unlike real bugs, these weren't alive enough to be worth sparing.
User avatar
TheXenomorph1
Poster of the New User Apocalypse
Poster of the New User Apocalypse
Posts: 2
Joined: Sun Dec 24, 2017 12:34 am

Camera/Mouse bug in creators with full DI GUI

Unread postby TheXenomorph1 » Sun Dec 24, 2017 12:46 am

Alright, I haven't seen a thread for this, so I dunno if it's just me or Dark Injection, but I've never had this happen before using Dark Injection.
When in any creator, the mouse/camera doesn't want to work or do anything when in a certain area, which usually tends to be around the outside of the normal area. I don't know if there's a reason for this, but it seems to only not work when the mouse is over where the normal spore GUI stuff would be for the creation's skills/attributes. I use the full Darkspore UI, so I believe that the issue lies only with that, but I'm unsure.
I know it says only one thing, but there's also a weird thing when you view creations from the sporepedia, where the GUI is the same as normal Spore but the buttons to edit/share/whatever else... aren't.
Neither of these are really that bad of a setback, just little oddities that I noticed and decided to mention.

User avatar
Darhagonable
Guru
Guru
Master Sergeant
Master Sergeant
Posts: 385
Joined: Mon Feb 23, 2015 9:37 am
Location: somewhere in the universe
Contact:

Re: Camera/Mouse bug in creators with full DI GUI

Unread postby Darhagonable » Sun Dec 24, 2017 3:51 am

Yeah it could be the fault of Dark injection.. It sounds to me like Rob forgot to change the Window Flag for some block/window.
Hopefully he'll fix it for the next public release (if it is the fault of DI).
Image
Image
Image
Image

User avatar
TheXenomorph1
Poster of the New User Apocalypse
Poster of the New User Apocalypse
Posts: 2
Joined: Sun Dec 24, 2017 12:34 am

Re: Camera/Mouse bug in creators with full DI GUI

Unread postby TheXenomorph1 » Sat Dec 30, 2017 2:01 am

Apparently this site doesn't tell you when someone has replied to a post, alright.
thanks for the reply though, good to know things are still being worked on.

User avatar
rob55rod
Tech Support
Tech Support
Sergeant Major of the Davo Army
Sergeant Major of the Davo Army
Posts: 3877
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.

Re: Camera/Mouse bug in creators with full DI GUI

Unread postby rob55rod » Sat Dec 30, 2017 12:16 pm

TheXenomorph1 wrote:Apparently this site doesn't tell you when someone has replied to a post, alright.
thanks for the reply though, good to know things are still being worked on.

Yeah, sorry about that...

I thought I'd fixed this issue a while ago...guess I missed something. Thanks for letting me know.
Having trouble with the Spore ModAPI Launcher Kit? Let us know here!

If you're reading this, you have my permission to build off of my mods as long as I am credited. Please don't mirror my work unaltered, unless I no longer provide a working download.

Osku
Poster of the New User Apocalypse
Poster of the New User Apocalypse
Posts: 1
Joined: Fri Feb 02, 2018 7:28 am

Re: Camera/Mouse bug in creators with full DI GUI

Unread postby Osku » Fri Feb 02, 2018 7:35 am

So.. is this fixed yet?

User avatar
rob55rod
Tech Support
Tech Support
Sergeant Major of the Davo Army
Sergeant Major of the Davo Army
Posts: 3877
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.

Re: Camera/Mouse bug in creators with full DI GUI

Unread postby rob55rod » Fri Feb 02, 2018 8:11 am

Osku wrote:So.. is this fixed yet?

Publicly, not yet. I've looked into it a bit internally, though.
Having trouble with the Spore ModAPI Launcher Kit? Let us know here!

If you're reading this, you have my permission to build off of my mods as long as I am credited. Please don't mirror my work unaltered, unless I no longer provide a working download.


Return to “Fixed Bugs”