Very LOUD editor sound effects + other bugs

Found a bug in a 9.r beta? Let us know here, so we can fix it.
Forum rules
1. Please post only ONE bug per THREAD. If you have multiple bugs to report, create a thread FOR EACH BUG.

2. Please NAME your THREADS as DESCRIPTIVELY as possible.

3. Please DO NOT CREATE report threads for bugs which have already been reported. This produces REDUNDANT BUG REPORTS, which slows down development by making it harder for me to read, reports and fix the bugs mentioned within them. This also applies for bugs which have been fixed and moved accordingly, so CHECK the FIXED BUGS subforum BEFORE POSTING. Previously-submitted bug reports can be found here: viewforum.php?f=174
First Class

First Class

paranoid_modder
User avatar
Posts: 58
Joined: Fri Apr 28, 2017 6:49 pm
Gender: None specified
Status: Offline

Very LOUD editor sound effects + other bugs

Unread post #1 by paranoid_modder » Sat Sep 23, 2017 5:56 pm

Ive been using DI 2.1.6 and i am using the black core-spore UI editor, along with the hero editor background, and i couldnt help but notice the ambient machinery sounds in the background are REALLY loud, louder then the rest of the entire game. i have to turn the volume down to under half just because of that...and also, sometimes the volume just goes back to being really loud again? I guess this is more of a suggestion, but the ambient editor sound imo should be a little lower.

another bug, which im not sure if is a feature or not, is that in the editor, the creatures have no animation anymore. normally, they would look around or make a sound when you arent editing them, but the models are just looping their "idle" animations over and over. I kinda missed having them look around, try out their new hand or just any little quirk, really.

then theres the category tabs, which have no titles, just named "***"


Image

Sergeant

Sergeant

Flames Kid
User avatar
Posts: 117
Joined: Mon Jan 23, 2017 12:52 pm
Location: Cryos
Gender: Male
Contact:
Status: Offline

Re: Very LOUD editor sound effects + other bugs

Unread post #2 by Flames Kid » Sat Sep 23, 2017 6:39 pm

paranoid_modder wrote:Ive been using DI 2.1.6 and i am using the black core-spore UI editor, along with the hero editor background, and i couldnt help but notice the ambient machinery sounds in the background are REALLY loud, louder then the rest of the entire game. i have to turn the volume down to under half just because of that...and also, sometimes the volume just goes back to being really loud again? I guess this is more of a suggestion, but the ambient editor sound imo should be a little lower.

another bug, which im not sure if is a feature or not, is that in the editor, the creatures have no animation anymore. normally, they would look around or make a sound when you arent editing them, but the models are just looping their "idle" animations over and over. I kinda missed having them look around, try out their new hand or just any little quirk, really.

then theres the category tabs, which have no titles, just named "***"


I too had noticed the loud editor but i dont know about the animations, i installed a mod that removes that but i didn't know of this happening otherwise
:di: I am just a simulation §§§§§§§
Image

First Class

First Class

paranoid_modder
User avatar
Posts: 58
Joined: Fri Apr 28, 2017 6:49 pm
Gender: None specified
Status: Offline

Re: Very LOUD editor sound effects + other bugs

Unread post #3 by paranoid_modder » Sat Sep 23, 2017 8:53 pm

i dont know, maybe some other mods are doing it? noticed it when i installed 2.1.6 and also, the background ambience sound is mixing other music inside sometimes..
Image

Sergeant

Sergeant

Flames Kid
User avatar
Posts: 117
Joined: Mon Jan 23, 2017 12:52 pm
Location: Cryos
Gender: Male
Contact:
Status: Offline

Re: Very LOUD editor sound effects + other bugs

Unread post #4 by Flames Kid » Sat Sep 23, 2017 9:14 pm

yea one of them keeps being copyrighted in my youtube vids as 'an iron frappe'
:di: I am just a simulation §§§§§§§
Image

Tech Support

Tech Support

rob55rod
User avatar
Posts: 3204
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.
Gender: Male
Status: Offline

Re: Very LOUD editor sound effects + other bugs

Unread post #5 by rob55rod » Sun Sep 24, 2017 4:38 am

Flames Kid wrote:yea one of them keeps being copyrighted in my youtube vids as 'an iron frappe'

Apparently that's the name of a song by Robert Fripp and/or Brian Eno...I know the Eno was involved in Spore's development, not sure about Fripp though...

paranoid_modder wrote:Ive been using DI 2.1.6 and i am using the black core-spore UI editor, along with the hero editor background, and i couldnt help but notice the ambient machinery sounds in the background are REALLY loud, louder then the rest of the entire game. i have to turn the volume down to under half just because of that...and also, sometimes the volume just goes back to being really loud again? I guess this is more of a suggestion, but the ambient editor sound imo should be a little lower.

Okay yeah you're not the only one to report that...I honestly had no idea, I have my system volume super low half the time (chronic headaches, k?) and at a reasonable level the other half, so I can easily see how that mistake could've slipped past me. In any case, apologies, I'll look into reducing the volume for the next build. Sorry about that >-<

paranoid_modder wrote:another bug, which im not sure if is a feature or not, is that in the editor, the creatures have no animation anymore. normally, they would look around or make a sound when you arent editing them, but the models are just looping their "idle" animations over and over. I kinda missed having them look around, try out their new hand or just any little quirk, really.

That is a feature, pulled straight out of Darkspore. The idea was that it helped add a bit to the feeling of "No, this isn't Spore, what are you talking about?", and also meant the creature wouldn't interrupt the player's creativity, allowing them to create faster, although I guess I should probably make it its own component, rather than being tied to a specific editor background...

paranoid_modder wrote:then theres the category tabs, which have no titles, just named "***"

Do you have the Darkspore Text component installed? If not, does installing it resolve this issue?

First Class

First Class

paranoid_modder
User avatar
Posts: 58
Joined: Fri Apr 28, 2017 6:49 pm
Gender: None specified
Status: Offline

Re: Very LOUD editor sound effects + other bugs

Unread post #6 by paranoid_modder » Sun Sep 24, 2017 1:45 pm

rob55rod wrote:
paranoid_modder wrote:Ive been using DI 2.1.6 and i am using the black core-spore UI editor, along with the hero editor background, and i couldnt help but notice the ambient machinery sounds in the background are REALLY loud, louder then the rest of the entire game. i have to turn the volume down to under half just because of that...and also, sometimes the volume just goes back to being really loud again? I guess this is more of a suggestion, but the ambient editor sound imo should be a little lower.

Okay yeah you're not the only one to report that...I honestly had no idea, I have my system volume super low half the time (chronic headaches, k?) and at a reasonable level the other half, so I can easily see how that mistake could've slipped past me. In any case, apologies, I'll look into reducing the volume for the next build. Sorry about that >-<

paranoid_modder wrote:another bug, which im not sure if is a feature or not, is that in the editor, the creatures have no animation anymore. normally, they would look around or make a sound when you arent editing them, but the models are just looping their "idle" animations over and over. I kinda missed having them look around, try out their new hand or just any little quirk, really.

That is a feature, pulled straight out of Darkspore. The idea was that it helped add a bit to the feeling of "No, this isn't Spore, what are you talking about?", and also meant the creature wouldn't interrupt the player's creativity, allowing them to create faster, although I guess I should probably make it its own component, rather than being tied to a specific editor background...

paranoid_modder wrote:then theres the category tabs, which have no titles, just named "***"

Do you have the Darkspore Text component installed? If not, does installing it resolve this issue?


1. yeah its not really a HUGE issue, but its kind of annoying, haha :lol:
2. again, i guess its more of a nitpick, so its up to you what you want to do with it, i just personally enjoyed them doing those animations, but i do understand why it was taken out, but again, your the one who decides :D
3. i thought darkspore text component was part of the darkspore UI, aka it was a custom font, so i didnt install it. i will add it now and see :o*

EDIT: i am so sorry about my bad formating OTL
Image


Return to “DI 9.r Bug Reports”

Who is online

Users browsing this forum: No registered users and 1 guest