12-24-2020
Due to an unexpected database update fail, the forum had to undergo a reset to an August backup. This sadly means all new user registations and content posted between 08-08-2020 and 12-24-2020 has been wiped. We apologize for the inconvenience and have taken measures to prevent this error from happening in the future.

Spore ModAPI not installing dark injection (beta 2.1.6)

Everything related to Dark Injection, a mod for Spore: Galactic Adventures which aims to extend the capabilities of Spore's editors and preserve Darkspore within Spore to the fullest extent possible.
Forum rules
Please be respectful and keep discussion at least loosely related to Darkspore and Dark Injection. If you are using the Dark Injection 9.r beta, we expect you to actually report any bugs you find, and to provide feedback whenever necessary.
User avatar
lucaswoop
Hatchling
Hatchling
Posts: 2
Joined: Mon Jan 22, 2018 12:04 pm

Spore ModAPI not installing dark injection (beta 2.1.6)

Unread post by lucaswoop »

Hello, I tried to install dark injection, but I get an error saying that the mod couldn't be installed, and that the "requested operation requires elevation". Does anybody know what this means? If you could help I'd be really appreciative.


User avatar
rob55rod
Admin
Admin
Posts: 4080
Joined: Sat Jul 02, 2011 9:50 am

Re: Spore ModAPI not installing dark injection (beta 2.1.6)

Unread post by rob55rod »

lucaswoop wrote:"requested operation requires elevation".
That means you forgot to run the ModAPI Easy Installer as Administrator.
Having trouble with the Spore ModAPI Launcher Kit? Get help here!

If you're reading this, you have my permission to build off of my mods as long as I am credited. Please don't mirror my work unaltered, unless I no longer provide a working download.
User avatar
lucaswoop
Hatchling
Hatchling
Posts: 2
Joined: Mon Jan 22, 2018 12:04 pm

Re: Spore ModAPI not installing dark injection (beta 2.1.6)

Unread post by lucaswoop »

rob55rod wrote:
lucaswoop wrote:"requested operation requires elevation".
That means you forgot to run the ModAPI Easy Installer as Administrator.
Oh, that worked. Thank you! Does this mean I also have to run the launcher and uninstaller as admin as well?
User avatar
rob55rod
Admin
Admin
Posts: 4080
Joined: Sat Jul 02, 2011 9:50 am

Re: Spore ModAPI not installing dark injection (beta 2.1.6)

Unread post by rob55rod »

lucaswoop wrote:
rob55rod wrote:
lucaswoop wrote:"requested operation requires elevation".
That means you forgot to run the ModAPI Easy Installer as Administrator.
Oh, that worked. Thank you! Does this mean I also have to run the launcher and uninstaller as admin as well?
Uninstaller yes. Launcher...not necessarily, but if something bursts into flames, you may as well try it.
Having trouble with the Spore ModAPI Launcher Kit? Get help here!

If you're reading this, you have my permission to build off of my mods as long as I am credited. Please don't mirror my work unaltered, unless I no longer provide a working download.
Post Reply Previous topicNext topic

Return to “Dark Injection”