DI Manual Installation.

Everything related to Dark Injection, a mod for Spore: Galactic Adventures which aims to extend the capabilities of Spore's editors and preserve Darkspore within Spore to the fullest extent possible.
Forum rules
Please be respectful and keep discussion atleast loosely related to Darkspore and Dark Injection. If you are using the Dark Injection 9.r beta, we expect you to actually report any bugs you find and provide feedback as necessary.
Poster of the New User Apocalypse

Poster of the New User Apocalypse

JohnConstantine
Posts: 4
Joined: Sat Mar 16, 2019 12:41 am

DI Manual Installation.

Unread postby JohnConstantine » Sat Mar 16, 2019 12:45 am

The dlls in my pc has a problem and no matter how I update it, the mod api installer still doesn't work. Isthere a way to manually install it?

Tech Support

Tech Support

rob55rod
User avatar
Posts: 3627
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.

Re: DI Manual Installation.

Unread postby rob55rod » Sat Mar 16, 2019 7:19 am

No, and I won't change that - even if you could manually install DI, you'd still need the Spore ModAPI Launcher Kit to use it, so there's really no point. What you're requesting is akin to saying that your car's steering wheel is broken, and then trying to walk to another country instead of getting your car fixed. So how about rather than doing that, you elaborate on what the problem is regarding the Spore ModAPI Launcher Kit, so we can actually resolve this problem?

Poster of the New User Apocalypse

Poster of the New User Apocalypse

JohnConstantine
Posts: 4
Joined: Sat Mar 16, 2019 12:41 am

Re: DI Manual Installation.

Unread postby JohnConstantine » Sat Mar 16, 2019 8:01 am

Hi. Thanks for responding. I didn't spill it out immediately because it is very out of the ordinary problems that you deal with every day... or not. But when I open the modapi, an error pops up and says that I don't have nextafterf in my msvcr120_clr0400.dll. I am pretty sure I have it since I always update my dlls and whatnot. I don't expect you to respond again but still thank you for giving people mods to enhance their gameplay and at the same time, provide support without asking for compensation. I appreciate it.

Tech Support

Tech Support

rob55rod
User avatar
Posts: 3627
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.

Re: DI Manual Installation.

Unread postby rob55rod » Sat Mar 16, 2019 9:02 am

JohnConstantine wrote:Hi. Thanks for responding.

No problem, let's see what we can do here...

JohnConstantine wrote:I didn't spill it out immediately because it is very out of the ordinary problems that you deal with every day... or not. But when I open the modapi, an error pops up and says that I don't have nextafterf in my msvcr120_clr0400.dll. I am pretty sure I have it since I always update my dlls and whatnot.

That is somewhat of an odd problem...are you able to provide a screenshot of this error message? And also, what operating system (and version of that operating system) are you using?

JohnConstantine wrote:I don't expect you to respond again but still

Of course I'm going to respond again - I sense a possibility that, with more information, I might be able to help you resolve this problem, and if I am able to, that would benefit both of us - you'd get to play Spore with DI and all the mods you want, and I'd get to learn more about how to resolve these problems, thus meaning that if there's ever another case where somebody has a problem like this one, I'll more prepared.
So long as I have any idea of how to continue trying to diagnose or resolve a problem, I will do so if at all possible.

JohnConstantine wrote:thank you for giving people mods to enhance their gameplay and at the same time, provide support without asking for compensation. I appreciate it.

Y'know, it really means a lot to me that you'd take the time to actually say that. I wouldn't exactly say people are generally ungrateful, that would be grossly inaccurate, but sometimes it seems as though they aren't necessarily aware of the scope of what I do, nor would I expect them to be. It's a lot of work, some of it fun, some of it absolutely agonizing, but these simple expressions of appreciation - knowing that people actually notice and benefit from my work - make it all worth every second of time I spend.

Poster of the New User Apocalypse

Poster of the New User Apocalypse

JohnConstantine
Posts: 4
Joined: Sat Mar 16, 2019 12:41 am

Re: DI Manual Installation.

Unread postby JohnConstantine » Sat Mar 16, 2019 11:14 pm

https://imgur.com/BaMu6Vc
This is what shows. I followed every instruction on how to fix the dll error I saw on google but no luck. Sorry if I'm asking too much.

Tech Support

Tech Support

rob55rod
User avatar
Posts: 3627
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.

Re: DI Manual Installation.

Unread postby rob55rod » Sun Mar 17, 2019 11:24 am

Alright, tell me...have you installed the Microsoft Visual C++ 2013 Redistributable, and/or any subsequent versions? If so, which?

Also don't worry about asking too much. You're not. but if you were, I'd let you know.

Poster of the New User Apocalypse

Poster of the New User Apocalypse

JohnConstantine
Posts: 4
Joined: Sat Mar 16, 2019 12:41 am

Re: DI Manual Installation.

Unread postby JohnConstantine » Sun Mar 17, 2019 8:32 pm

rob55rod wrote:Alright, tell me...have you installed the Microsoft Visual C++ 2013 Redistributable, and/or any subsequent versions? If so, which?

Also don't worry about asking too much. You're not. but if you were, I'd let you know.


Yes I have and in fact, I uninstalled and installed it. Please do let me know if I'm asking too much, I don't want to be a choosing beggar. Also, should I try installing windows 10? I have been thinking about it but I'm afraid of constant updates as I always have short deadlines. Perhaps that could fix the problem?

Tech Support

Tech Support

rob55rod
User avatar
Posts: 3627
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.

Re: DI Manual Installation.

Unread postby rob55rod » Mon Mar 18, 2019 8:36 am

JohnConstantine wrote:Yes I have and in fact, I uninstalled and installed it.

Hmm...in that case, do you have the Microsoft Visual C++ 2015 Redistributable installed as well?

JohnConstantine wrote:Also, should I try installing windows 10?
JohnConstantine wrote:Perhaps that could fix the problem?

Definitely not, Windows 10 will only make things worse. Spore is an old game, and its age is starting to show on Windows 10. If you're on Windows 7 or 8.1, I'd advise staying there.


JohnConstantine wrote:I have been thinking about it but I'm afraid of constant updates as I always have short deadlines.

You're not the only one who finds the idea of constant forced updates repulsive. That's one of the main reasons why I've chosen to remain on Windows 8.1 instead of upgrading.


Return to “Dark Injection”

Who is online

Users browsing this forum: No registered users and 1 guest