Official Dark Injection FAQ! Answers and Fixes!

Here you can find information regarding Dark Injection, or post questions if you need further help.
isdebesl
Recruit
Recruit
Posts: 24
Joined: Thu Jun 27, 2013 8:40 pm

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread postby isdebesl » Sat Apr 04, 2015 5:05 am

isdebesl wrote:It varies between different graphics cards, some people can see them only in build mode, some can see them in build, paint, and test drive, and a few unlucky people can see them everywhere.

well actually i have 4gb ram, but the processor is intel i3, maybe that's the problem, any is there any alternatives for that? i want to learn to be a good creator(maybe)

User avatar
rob55rod
Tech Support
Tech Support
Sergeant Major of the Davo Army
Sergeant Major of the Davo Army
Posts: 3776
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread postby rob55rod » Sat Apr 04, 2015 10:30 am

isdebesl wrote:
isdebesl wrote:It varies between different graphics cards, some people can see them only in build mode, some can see them in build, paint, and test drive, and a few unlucky people can see them everywhere.

well actually i have 4gb ram, but the processor is intel i3, maybe that's the problem, any is there any alternatives for that? i want to learn to be a good creator(maybe)

Look, there's no good way to know what cards will and won't work correctly. It's all a matter of either guesswork or inquiry.
Having trouble with the Spore ModAPI Launcher Kit? Let us know here!

If you're reading this, you have my permission to build off of my mods as long as I am credited. Please don't mirror my work unaltered, unless I no longer provide a working download.

Ihuman12345
Recruit
Recruit
Posts: 5
Joined: Mon May 18, 2015 4:52 am

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread postby Ihuman12345 » Thu May 21, 2015 6:40 am

I know this is an old thread and you probably finished answering questions but whenever i try to use darkspore parts it becomes invisible and i know you answered that question already but i already installed GA,patched it to 1.5.1 and have even REDONE the WHOLE PROCESS OF INSTALLING SPORE. I dont mean to be a hater or anything but could at least help me pls

User avatar
rob55rod
Tech Support
Tech Support
Sergeant Major of the Davo Army
Sergeant Major of the Davo Army
Posts: 3776
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread postby rob55rod » Thu May 21, 2015 6:55 am

Ihuman12345 wrote:I know this is an old thread and you probably finished answering questions but whenever i try to use darkspore parts it becomes invisible and i know you answered that question already but i already installed GA,patched it to 1.5.1 and have even REDONE the WHOLE PROCESS OF INSTALLING SPORE. I dont mean to be a hater or anything but could at least help me pls

Not sure how you concluded that this thread is "old", but yes, I'm more than happy to help. For starters, did you install Arenas_RDX9.package and Arenas_Textures.package? If not, then that's the source of the problem.
Having trouble with the Spore ModAPI Launcher Kit? Let us know here!

If you're reading this, you have my permission to build off of my mods as long as I am credited. Please don't mirror my work unaltered, unless I no longer provide a working download.

Ihuman12345
Recruit
Recruit
Posts: 5
Joined: Mon May 18, 2015 4:52 am

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread postby Ihuman12345 » Thu May 21, 2015 7:03 am

rob55rod wrote:
Ihuman12345 wrote:I know this is an old thread and you probably finished answering questions but whenever i try to use darkspore parts it becomes invisible and i know you answered that question already but i already installed GA,patched it to 1.5.1 and have even REDONE the WHOLE PROCESS OF INSTALLING SPORE. I dont mean to be a hater or anything but could at least help me pls


Not sure how you concluded that this thread is "old", but yes, I'm more than happy to help. For starters, did you install Arenas_RDX9.package and Arenas_Textures.package? If not, then that's the source of the problem.

yes i did
Last edited by Ihuman12345 on Thu May 21, 2015 7:16 am, edited 1 time in total.

User avatar
rob55rod
Tech Support
Tech Support
Sergeant Major of the Davo Army
Sergeant Major of the Davo Army
Posts: 3776
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread postby rob55rod » Thu May 21, 2015 7:12 am

Ihuman12345 wrote:yes i did

Alright, that's a bit odd. What variant of Spore are you using? Disk, Origin, or Steam? If you're using Spore on Origin, or the variant sold on Steam, try these packages:
Arenas_RDX9
Arenas_Textures
instead of the ones Davo provided. (IIRC) his versions have some unneeded stuff trimmed out, but for some reason, they don't seem to work for some users. The links I provided above are to the unmodified packages, taken straight from Darkspore. They seem to work better for most users who have these kinds of problems.
Having trouble with the Spore ModAPI Launcher Kit? Let us know here!

If you're reading this, you have my permission to build off of my mods as long as I am credited. Please don't mirror my work unaltered, unless I no longer provide a working download.

Ihuman12345
Recruit
Recruit
Posts: 5
Joined: Mon May 18, 2015 4:52 am

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread postby Ihuman12345 » Thu May 21, 2015 7:26 am

rob55rod wrote:
Ihuman12345 wrote:yes i did

Alright, that's a bit odd. What variant of Spore are you using? Disk, Origin, or Steam? If you're using Spore on Origin, or the variant sold on Steam, try these packages:
Arenas_RDX9
Arenas_Textures
instead of the ones Davo provided. (IIRC) his versions have some unneeded stuff trimmed out, but for some reason, they don't seem to work for some users. The links I provided above are to the unmodified packages, taken straight from Darkspore. They seem to work better for most users who have these kinds of problems.

Ill try them and tell you . My internet is slow so i have to wait

User avatar
rob55rod
Tech Support
Tech Support
Sergeant Major of the Davo Army
Sergeant Major of the Davo Army
Posts: 3776
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread postby rob55rod » Thu May 21, 2015 7:36 am

Ihuman12345 wrote:
rob55rod wrote:
Ihuman12345 wrote:yes i did

Alright, that's a bit odd. What variant of Spore are you using? Disk, Origin, or Steam? If you're using Spore on Origin, or the variant sold on Steam, try these packages:
Arenas_RDX9
Arenas_Textures
instead of the ones Davo provided. (IIRC) his versions have some unneeded stuff trimmed out, but for some reason, they don't seem to work for some users. The links I provided above are to the unmodified packages, taken straight from Darkspore. They seem to work better for most users who have these kinds of problems.

Ill try them and tell you . My internet is slow so i have to wait

Oh, alright. Mine too, actually, those files took days to upload :lol: (I uploaded them a while ago .__. )
Having trouble with the Spore ModAPI Launcher Kit? Let us know here!

If you're reading this, you have my permission to build off of my mods as long as I am credited. Please don't mirror my work unaltered, unless I no longer provide a working download.

Ihuman12345
Recruit
Recruit
Posts: 5
Joined: Mon May 18, 2015 4:52 am

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread postby Ihuman12345 » Thu May 21, 2015 1:53 pm

they didnt work am i doing something wrong?

User avatar
rob55rod
Tech Support
Tech Support
Sergeant Major of the Davo Army
Sergeant Major of the Davo Army
Posts: 3776
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread postby rob55rod » Thu May 21, 2015 2:25 pm

Ihuman12345 wrote:they didnt work am i doing something wrong?

I'm not sure. I'll need you to answer a few questions before I can try to further diagnose this problem:
-Where did you buy Spore? Origin, Steam, or on a disk from a store?
-Which expansion packs do you have, if any? And do you have them from the same source as the core game?
I'll also need you to list all the files in your Spore data folder, and your Spore GA data folder, if you have GA.
Having trouble with the Spore ModAPI Launcher Kit? Let us know here!

If you're reading this, you have my permission to build off of my mods as long as I am credited. Please don't mirror my work unaltered, unless I no longer provide a working download.

Ihuman12345
Recruit
Recruit
Posts: 5
Joined: Mon May 18, 2015 4:52 am

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread postby Ihuman12345 » Fri May 22, 2015 2:08 am

rob55rod wrote:
Ihuman12345 wrote:they didnt work am i doing something wrong?

I'm not sure. I'll need you to answer a few questions before I can try to further diagnose this problem:
-Where did you buy Spore? Origin, Steam, or on a disk from a store?
-Which expansion packs do you have, if any? And do you have them from the same source as the core game?
I'll also need you to list all the files in your Spore data folder, and your Spore GA data folder, if you have GA.

oh nevermind now. i installed spore with my friends cd and dark injections worked perfectly fine! idk why it didnt work on my cd :D :D :D

User avatar
rob55rod
Tech Support
Tech Support
Sergeant Major of the Davo Army
Sergeant Major of the Davo Army
Posts: 3776
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread postby rob55rod » Fri May 22, 2015 4:00 am

Ihuman12345 wrote:
rob55rod wrote:
Ihuman12345 wrote:they didnt work am i doing something wrong?

I'm not sure. I'll need you to answer a few questions before I can try to further diagnose this problem:
-Where did you buy Spore? Origin, Steam, or on a disk from a store?
-Which expansion packs do you have, if any? And do you have them from the same source as the core game?
I'll also need you to list all the files in your Spore data folder, and your Spore GA data folder, if you have GA.

oh nevermind now. i installed spore with my friends cd and dark injections worked perfectly fine! idk why it didnt work on my cd :D :D :D

Oh, alright. Odd. Regardless, I'm glad to see the problem is solved :mrgreen:

Also, I should note the DI 9.r Mini-release. Feel free to try it out, but also feel free to...not. I won't mind :lol:
Having trouble with the Spore ModAPI Launcher Kit? Let us know here!

If you're reading this, you have my permission to build off of my mods as long as I am credited. Please don't mirror my work unaltered, unless I no longer provide a working download.

Titanophis
Poster of the New User Apocalypse
Poster of the New User Apocalypse
Posts: 1
Joined: Fri May 29, 2015 1:48 pm

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread postby Titanophis » Sun May 31, 2015 4:31 pm

How do you get the mods onto spore GA if you downloaded it from origin(if possible. If not, may I kindly ask you to figure out a way to got the mods into the game)????????? I don't have a data directory because of it being from origin.

User avatar
rob55rod
Tech Support
Tech Support
Sergeant Major of the Davo Army
Sergeant Major of the Davo Army
Posts: 3776
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread postby rob55rod » Sun May 31, 2015 5:32 pm

Titanophis wrote:How do you get the mods onto spore GA if you downloaded it from origin(if possible. If not, may I kindly ask you to figure out a way to got the mods into the game)????????? I don't have a data directory because of it being from origin.

Image
You do have a Data directory, it's just in a different location. If you accepted the default path, it'd be at

Code: Select all

C:\Program Files (x86)\Origin Games\Spore Galactic Adventures\Data
Having trouble with the Spore ModAPI Launcher Kit? Let us know here!

If you're reading this, you have my permission to build off of my mods as long as I am credited. Please don't mirror my work unaltered, unless I no longer provide a working download.

isdebesl
Recruit
Recruit
Posts: 24
Joined: Thu Jun 27, 2013 8:40 pm

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread postby isdebesl » Thu Jun 18, 2015 8:57 am

is the gray pipes bug fixed in dark injection 9.r?

User avatar
rob55rod
Tech Support
Tech Support
Sergeant Major of the Davo Army
Sergeant Major of the Davo Army
Posts: 3776
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread postby rob55rod » Thu Jun 18, 2015 10:20 am

isdebesl wrote:is the gray pipes bug fixed in dark injection 9.r?

No. It isn't the mod's fault, so go buy a new graphics card and cross your fingers it'll do the trick.
Having trouble with the Spore ModAPI Launcher Kit? Let us know here!

If you're reading this, you have my permission to build off of my mods as long as I am credited. Please don't mirror my work unaltered, unless I no longer provide a working download.

User avatar
Martin the Wolf
Recruit
Recruit
Posts: 7
Joined: Tue Mar 31, 2015 5:27 pm

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread postby Martin the Wolf » Mon Jul 06, 2015 2:46 pm

For some reason, sometimes when I play Spore DI, it sometimes minimizes (and by minimize, I mean minimize, not crash) with the message 'dwm.exe has stopped working', it started happening ever since I've downloaded DI.
A screenshot of the message: Here.
Though, it doesn't happen much, but it's still irritating. How can I fix it?
Here is my Spore Info:
-Patch 5.
-GA Expansion
-No other mods.
-Disk Version

User avatar
rob55rod
Tech Support
Tech Support
Sergeant Major of the Davo Army
Sergeant Major of the Davo Army
Posts: 3776
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread postby rob55rod » Mon Jul 06, 2015 3:27 pm

Martin the Wolf wrote:For some reason, sometimes when I play Spore DI, it sometimes minimizes (and by minimize, I mean minimize, not crash) with the message 'dwm.exe has stopped working', it started happening ever since I've downloaded DI.
A screenshot of the message: Here.
Though, it doesn't happen much, but it's still irritating. How can I fix it?
Here is my Spore Info:
-Patch 5.
-GA Expansion
-No other mods.
-Disk Version

Um...DI doesn't have the ability to cause that, unless it's a memory use issue, but even then, it's unlikely that there's a connection. Also, in that screeny, I can clearly see that DWM is indeed working. I have no idea why this is happening, that is really weird.

A bit of an explanation as to what DWM is:
DWM (Desktop Window Manager) is a component of Windows introduced in Windows Vista. It does a number of things, including the "Aero Glass" effect, 3D Flip (the WIN+TAB thing that flips through all open windows in a 3-dimensional manner), GPU-rendered Windows, and some other stuff. Closing has the same effect as switching to Windows Basic. On Windows 8 and later, this would be a big problem, as the Modern UI, panic screen, and login screen are dependant on DWM, but I see that you're using Windows 7, so it shouldn't be much of an issue.

You should be able to stop the messages by switching to the Windows Basic theme, or by enabling "Disable Desktop Composition" in the properties for GA's SporeApp.exe, which will cause Windows to automatically switch you to Windows Basic whenever you launch Spore, and switch back when you close it. I imagine the latter would be preferable. While it's not the ideal, clean fix I assume you were hoping for, it should atleast solve the problem, so I hope that's sufficient. Let me know if you see results!
Having trouble with the Spore ModAPI Launcher Kit? Let us know here!

If you're reading this, you have my permission to build off of my mods as long as I am credited. Please don't mirror my work unaltered, unless I no longer provide a working download.

bnguyen93
Poster of the New User Apocalypse
Poster of the New User Apocalypse
Posts: 1
Joined: Fri Aug 07, 2015 11:23 pm

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread postby bnguyen93 » Sun Aug 09, 2015 12:59 pm

why my invisibility bone doesn't gone when i change to color like the video of DarkEdgeTV ???

User avatar
rob55rod
Tech Support
Tech Support
Sergeant Major of the Davo Army
Sergeant Major of the Davo Army
Posts: 3776
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread postby rob55rod » Sun Aug 09, 2015 1:37 pm

bnguyen93 wrote:why my invisibility bone doesn't gone when i change to color like the video of DarkEdgeTV ???

Because you don't have an extraordinarily unusual computer.
Having trouble with the Spore ModAPI Launcher Kit? Let us know here!

If you're reading this, you have my permission to build off of my mods as long as I am credited. Please don't mirror my work unaltered, unless I no longer provide a working download.


Return to “FAQ, Info, and Help”