Official Dark Injection FAQ! Answers and Fixes!

Here you can find information regarding Dark Injection, or post questions if you need further help.
User avatar
VanillaCold
Staff Sergeant
Staff Sergeant
Posts: 183
Joined: Fri Nov 02, 2018 2:36 pm
Contact:

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread postby VanillaCold » Thu Jan 03, 2019 8:29 am

SilverGallium wrote:Now, everything is in the game when launched from the entry for :ga: in my Steam library, and the newest version of the mod changes the UI as intended, but the game crashes shortly after startup! It's the closest I've gotten so far, but certainly not what I wanted.

If this is your first time launching GA, uninstall all mods and reinstall them after launching an unmodded copy of GA.
If it isn't, try verifying the game's files.
Creator of Solar Spore, Adventure Water and Spaceplanes.

My main account broke a while ago, so I created this alt.

User avatar
rob55rod
Tech Support
Tech Support
Sergeant Major of the Davo Army
Sergeant Major of the Davo Army
Posts: 3772
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread postby rob55rod » Thu Jan 03, 2019 1:11 pm

VanillaCold wrote:After updating to the latest verison of the ModAPI, my game's started failing to detect the ModAPI too.
https://steamcommunity.com/sharedfiles/ ... 1613008307
My DataEP1 folder:
DataEP1.png

My copy of the ModAPI is located in D:\Steam\steamapps\common\Spore\ModAPI.

EDIT: I've found a temporary solution to this problem: Launch Spore with the launch option "-state:creatureeditor".
For some reason, launching the creature editor before reaching the main menu cancels the ModAPI detection.

That's not a solution. Just because you've managed to circumvent the warning message doesn't mean the problem is solved. If it was solved, you wouldn't be seeing that warning.

Please elaborate on exactly what the problem is.
Having trouble with the Spore ModAPI Launcher Kit? Let us know here!

If you're reading this, you have my permission to build off of my mods as long as I am credited. Please don't mirror my work unaltered, unless I no longer provide a working download.

User avatar
VanillaCold
Staff Sergeant
Staff Sergeant
Posts: 183
Joined: Fri Nov 02, 2018 2:36 pm
Contact:

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread postby VanillaCold » Fri Jan 04, 2019 6:13 am

rob55rod wrote:Please elaborate on exactly what the problem is.

The check for the ModAPI is broken, as when Spore is launched with the ModAPI, it still gives me the image I linked on my previous post.
Creator of Solar Spore, Adventure Water and Spaceplanes.

My main account broke a while ago, so I created this alt.

User avatar
rob55rod
Tech Support
Tech Support
Sergeant Major of the Davo Army
Sergeant Major of the Davo Army
Posts: 3772
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread postby rob55rod » Fri Jan 04, 2019 6:26 am

VanillaCold wrote:
rob55rod wrote:Please elaborate on exactly what the problem is.

The check for the ModAPI is broken, as when Spore is launched with the ModAPI, it still gives me the image I linked on my previous post.

...I misread your initial post on the matter.

Not entirely sure when you posted this, but there was another update yesterday, which has been reported to help. Try that. If it doesn't help...

Try going to %appdata% and deleting the "Spore ModAPI Launcher" folder. See if that helps. If not, then tell me...do you get any other messages prior to starting the game? If not, can you create a new text document called "debug.txt" in your ModAPI Launcher Kit folder, and then send me all of the messageboxes the ModAPI Launcher produces the next time you run it?
Having trouble with the Spore ModAPI Launcher Kit? Let us know here!

If you're reading this, you have my permission to build off of my mods as long as I am credited. Please don't mirror my work unaltered, unless I no longer provide a working download.

User avatar
VanillaCold
Staff Sergeant
Staff Sergeant
Posts: 183
Joined: Fri Nov 02, 2018 2:36 pm
Contact:

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread postby VanillaCold » Fri Jan 04, 2019 12:22 pm

rob55rod wrote:
VanillaCold wrote:Not entirely sure when you posted this, but there was another update yesterday, which has been reported to help. Try that. If it doesn't help...

Try going to %appdata% and deleting the "Spore ModAPI Launcher" folder. See if that helps. If not, then tell me...do you get any other messages prior to starting the game? If not, can you create a new text document called "debug.txt" in your ModAPI Launcher Kit folder, and then send me all of the messageboxes the ModAPI Launcher produces the next time you run it?

Either the latest update or the removal of the folder in Appdata fixed it. Thanks! Image
Creator of Solar Spore, Adventure Water and Spaceplanes.

My main account broke a while ago, so I created this alt.

Sucidal
Poster of the New User Apocalypse
Poster of the New User Apocalypse
Posts: 1
Joined: Wed Jan 16, 2019 8:06 am

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread postby Sucidal » Wed Jan 16, 2019 8:14 am

Soo i bought spore and spore galactic adventures on steam than i installed sporemod API and dark injections with it but then when i launch the spore trough sporemodAPI launcher it says that it cant detect my games and window will pop up that i choose from what i got the game soo i chose Steam/GOG option and than error shows that says that i am missing api-ms-crt-runtime-I1-1-0-.dll and that i should reinstall the program soo i did reinstalled sporemodAPI and reinstalled dark injections and tryed again and it showed the same thing but another error showed up that says *Could not execute Spore galactic adventures.Wait for single object failed.* (also the game launches too but when it loads it says that i dont have it open trough sporemodAPI soo i have to exit it) and also run the sporemodAPI as administrator

SnowyElephantOffical
Poster of the New User Apocalypse
Poster of the New User Apocalypse
Posts: 1
Joined: Sat Jan 19, 2019 7:51 pm

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread postby SnowyElephantOffical » Sat Jan 19, 2019 7:57 pm

Ok, So I have recently got GA from Origin just so I can play Dark Injection Mod with the game. ( Because, well, it is awesome!). However, I did everything it said too such as patch, get the mod install api and then dragged the main mod file into the Data folder of GA then proceeded to install it and launched with the API Launcher. The game goes black (Doesn't load anything), then flashes continuously until I am forced to shut down my pc (Because task manager, Alt-f4 and such doesn't work.)

I have uninstalled and reinstalled the mods and game but, it always does this. I have been at it for 4 hours now and I have no Idea what went wrong or how to fix it. Please help! Also, willing to answer questions that may help you help me! Thank you in advance! :D :ga: :ga: :ga:

P.S : I got it for steam now and it did the same thing. I don't know if it matters but I use windows 10.

User avatar
rob55rod
Tech Support
Tech Support
Sergeant Major of the Davo Army
Sergeant Major of the Davo Army
Posts: 3772
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread postby rob55rod » Sun Jan 20, 2019 7:10 am

SnowyElephantOffical wrote:dragged the main mod file into the Data folder of GA

Don't lol
Having trouble with the Spore ModAPI Launcher Kit? Let us know here!

If you're reading this, you have my permission to build off of my mods as long as I am credited. Please don't mirror my work unaltered, unless I no longer provide a working download.

cstep3
Poster of the New User Apocalypse
Poster of the New User Apocalypse
Posts: 1
Joined: Sat Jan 19, 2019 6:15 am

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread postby cstep3 » Sun Jan 20, 2019 9:30 am

Hello. I would like to adress my problem

So i installed with modapi, all that jazz and when i open up the launcher it goes black and doesnt respond at all. I need help :cry:

User avatar
rob55rod
Tech Support
Tech Support
Sergeant Major of the Davo Army
Sergeant Major of the Davo Army
Posts: 3772
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread postby rob55rod » Sun Jan 20, 2019 12:54 pm

cstep3 wrote:Hello. I would like to adress my problem

So i installed with modapi, all that jazz and when i open up the launcher it goes black and doesnt respond at all. I need help :cry:

Can you be a bit more specific? Walk me through how you installed the mod in as much detail as possible, and elaborate on what exactly it is that "goes black" and what exactly you mean by "doesnt respond at all".
Having trouble with the Spore ModAPI Launcher Kit? Let us know here!

If you're reading this, you have my permission to build off of my mods as long as I am credited. Please don't mirror my work unaltered, unless I no longer provide a working download.

pederiic123435778
Poster of the New User Apocalypse
Poster of the New User Apocalypse
Posts: 1
Joined: Tue Jan 22, 2019 6:21 pm

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread postby pederiic123435778 » Tue Jan 22, 2019 6:26 pm

hello,I am trying to add the mod on my spore galactic adventures but when I start the game an alert box sais that MODapi is not detected even when I launch the game with MODapi´s launcher,what should I do?

User avatar
Kyumiterasu
Recruit
Recruit
Posts: 7
Joined: Sun Jan 13, 2019 12:24 am
Location: ಠ_ಠ
Contact:

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread postby Kyumiterasu » Wed Jan 23, 2019 12:10 pm

Is there a version of SporeMod API for Mac? I'm trying to install DI on my Macbook.

User avatar
rob55rod
Tech Support
Tech Support
Sergeant Major of the Davo Army
Sergeant Major of the Davo Army
Posts: 3772
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread postby rob55rod » Wed Jan 23, 2019 12:37 pm

Kyumiterasu wrote:Is there a version of SporeMod API for Mac? I'm trying to install DI on my Macbook.

No, sorry. The ModAPI, unfortunately, is Windows-exclusive for the time being. There are ways to run Windows on a Macbook, though, such as BootCamp...
Having trouble with the Spore ModAPI Launcher Kit? Let us know here!

If you're reading this, you have my permission to build off of my mods as long as I am credited. Please don't mirror my work unaltered, unless I no longer provide a working download.

User avatar
Kyumiterasu
Recruit
Recruit
Posts: 7
Joined: Sun Jan 13, 2019 12:24 am
Location: ಠ_ಠ
Contact:

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread postby Kyumiterasu » Wed Jan 23, 2019 7:25 pm

rob55rod wrote:
Kyumiterasu wrote:Is there a version of SporeMod API for Mac? I'm trying to install DI on my Macbook.

No, sorry. The ModAPI, unfortunately, is Windows-exclusive for the time being. There are ways to run Windows on a Macbook, though, such as BootCamp...

Damn. Is there any way to get a version of Dark Injections on Mac? Without an emulator?

User avatar
rob55rod
Tech Support
Tech Support
Sergeant Major of the Davo Army
Sergeant Major of the Davo Army
Posts: 3772
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread postby rob55rod » Thu Jan 24, 2019 12:24 pm

Kyumiterasu wrote:
rob55rod wrote:
Kyumiterasu wrote:Is there a version of SporeMod API for Mac? I'm trying to install DI on my Macbook.

No, sorry. The ModAPI, unfortunately, is Windows-exclusive for the time being. There are ways to run Windows on a Macbook, though, such as BootCamp...

Damn. Is there any way to get a version of Dark Injections on Mac? Without an emulator?

Currently, no. The issue is less DI itself and more the Spore ModAPI Launcher Kit. That having been said, while I haven't a clue if there's any hope of doing so, I'd definitely like to bring the Spore ModAPI Launcher Kit to macOS...but without regular access to someone who has a mac of some sort, I have no way of even being able to investigate the possibility of doing so.




Any chance you'd be open to lending a hand?
Having trouble with the Spore ModAPI Launcher Kit? Let us know here!

If you're reading this, you have my permission to build off of my mods as long as I am credited. Please don't mirror my work unaltered, unless I no longer provide a working download.

User avatar
Kyumiterasu
Recruit
Recruit
Posts: 7
Joined: Sun Jan 13, 2019 12:24 am
Location: ಠ_ಠ
Contact:

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread postby Kyumiterasu » Fri Jan 25, 2019 8:52 pm

rob55rod wrote:
Kyumiterasu wrote:
rob55rod wrote:No, sorry. The ModAPI, unfortunately, is Windows-exclusive for the time being. There are ways to run Windows on a Macbook, though, such as BootCamp...

Damn. Is there any way to get a version of Dark Injections on Mac? Without an emulator?

Currently, no. The issue is less DI itself and more the Spore ModAPI Launcher Kit. That having been said, while I haven't a clue if there's any hope of doing so, I'd definitely like to bring the Spore ModAPI Launcher Kit to macOS...but without regular access to someone who has a mac of some sort, I have no way of even being able to investigate the possibility of doing so.




Any chance you'd be open to lending a hand?


Sure! I'll be happy to contribute to this!

User avatar
rob55rod
Tech Support
Tech Support
Sergeant Major of the Davo Army
Sergeant Major of the Davo Army
Posts: 3772
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread postby rob55rod » Sat Jan 26, 2019 7:09 am

Kyumiterasu wrote:
rob55rod wrote:
Kyumiterasu wrote:Damn. Is there any way to get a version of Dark Injections on Mac? Without an emulator?

Currently, no. The issue is less DI itself and more the Spore ModAPI Launcher Kit. That having been said, while I haven't a clue if there's any hope of doing so, I'd definitely like to bring the Spore ModAPI Launcher Kit to macOS...but without regular access to someone who has a mac of some sort, I have no way of even being able to investigate the possibility of doing so.




Any chance you'd be open to lending a hand?


Sure! I'll be happy to contribute to this!

Great to hear. If you use Discord, I think that would be a better place to meet up to discuss this further, if you're open to that...
Having trouble with the Spore ModAPI Launcher Kit? Let us know here!

If you're reading this, you have my permission to build off of my mods as long as I am credited. Please don't mirror my work unaltered, unless I no longer provide a working download.

CurrentYearLolcat
Poster of the New User Apocalypse
Poster of the New User Apocalypse
Posts: 2
Joined: Fri Jan 25, 2019 12:07 pm

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread postby CurrentYearLolcat » Sat Jan 26, 2019 12:01 pm

Hello, I can't seem to open Spore with DI installed, other mods work fine though, and there are no issues launching without DI installed. I downloaded Dark Injection from the official website with seemingly no issues and successfully installed it via the ModAPI installer (ran as admin). When I try to launch Spore with the ModAPI launcher (again, as admin), I get an error with:
SporeModAPI_Launcher.InjectException
Wait for single object failed.

After looking through this thread I saw some people were missing ARENA files, and after looking in the Spore GA Data folder, I realized I was missing them as well. Where do I get them if they weren't included in the download from the site?

Edit: Got rid of the screenshots because they were eeyuge.
Last edited by CurrentYearLolcat on Sat Jan 26, 2019 3:21 pm, edited 1 time in total.

User avatar
XRealX
Poster of the New User Apocalypse
Poster of the New User Apocalypse
Posts: 4
Joined: Tue Jan 01, 2019 10:32 am

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread postby XRealX » Sat Jan 26, 2019 12:06 pm

Hello guys! Dark Injection 9.r 2.3.0 just crashes for me after I installed it and launched Spore with Spore ModAPI Launcher.

Before installing DI 9.r I had mods installed, but I removed them all after the game crashed.
After I removed all the mods except for DI 9.r the game still crashed.

I removed all the mods, including DI 9.r, and the game launched. It did not crash.
After I installed DI 9.r (justDI 9.r, not even force save), the game crashed again. And it keeps crashing.

I installed DI 9.r with the Spore ModAPI Easy Installer.

I have Spore, Galactic Adventures and Creepy & Cute Parts all patched to v5.1.
Last edited by XRealX on Sat Jan 26, 2019 1:26 pm, edited 1 time in total.

User avatar
rob55rod
Tech Support
Tech Support
Sergeant Major of the Davo Army
Sergeant Major of the Davo Army
Posts: 3772
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread postby rob55rod » Sat Jan 26, 2019 1:20 pm

CurrentYearLolcat wrote:When I try to launch Spore with the ModAPI launcher (again, as admin)

There's no need to run the ModAPI Launcher as an Administrator

CurrentYearLolcat wrote:I get an error with: -snip-

Is that the only error you see?

CurrentYearLolcat wrote:After looking through this thread I saw some people were missing ARENA files, and after looking in the Spore GA Data folder, I realized I was missing them as well. Where do I get them if they weren't included in the download from the site?

Those two packages have nothing to do with this. They aren't even needed for DI 9.r Public Beta 2.3.0, and even when they were, they should never have landed in your GA Data folder. All the required packages are included in the download from the site, and those two deliberately aren't included.


XRealX wrote:Hello guys! Dark Injection 9.r 2.3.0 just crashes for me after I installed it and launched Spore with Spore ModAPI Launcher.

Before installing DI 9.r I had mods installed, but I removed them all after the game crashed.
After I removed all the mods except for DI 9.r the game still crashed.

I removed all the mods, including DI 9.r, and the game launched. It did not crash.
After I installed DI 9.r (justDI 9.r, not even force save), the game crashed again. And it keeps crashing.

I installed DI 9.r with the Spore ModAPI Easy Installer.

I have Spore, Galactic Adventures and Creepy & Cute Parts all patched to v5.1.

Public Beta 2.3.2 was supposed to be released yesterday specifically to address this issue, but IRL prevented me from having a chance to update the website. It's up now.
Having trouble with the Spore ModAPI Launcher Kit? Let us know here!

If you're reading this, you have my permission to build off of my mods as long as I am credited. Please don't mirror my work unaltered, unless I no longer provide a working download.


Return to “FAQ, Info, and Help”