Official Dark Injection FAQ! Answers and Fixes!

Here you can find information regarding Dark Injection, or post questions if you need further help.
Ifeng
Poster of the New User Apocalypse
Poster of the New User Apocalypse
Posts: 1
Joined: Sun Jan 03, 2016 6:05 pm

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread postby Ifeng » Sun Jan 03, 2016 6:09 pm

HELP! When I'm creating a creature the things to rotate and change the size of a part are massive and it glitches a bit. Anyone know how to fix this?

oblatrate
Poster of the New User Apocalypse
Poster of the New User Apocalypse
Posts: 3
Joined: Mon Jan 04, 2016 10:43 am

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread postby oblatrate » Wed Jan 06, 2016 1:38 am

Hello! Massive fan of your mod.
I do have a slight problem though, the custom limbs added via this mod, both visible and invisible, will go onto the creation but won't connect to form, well, a functioning limb. I've tried all sorts of different mix and matches to see if maybe I'm not doing it right but no cigar.
I had installed my game from Origin quite sometime ago, all patches up to date and everything had been installed as laid out in your directions. Maybe I'm missing something here? I'm very no good at modding so perhaps I made a simple mistake~

((If this is an already answered question I apologize, I doublechecked in archives but maybe I missed it!))

User avatar
rob55rod
Tech Support
Tech Support
Sergeant Major of the Davo Army
Sergeant Major of the Davo Army
Posts: 3776
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread postby rob55rod » Wed Jan 06, 2016 3:46 am

oblatrate wrote:Hello! Massive fan of your mod.
I do have a slight problem though, the custom limbs added via this mod, both visible and invisible, will go onto the creation but won't connect to form, well, a functioning limb. I've tried all sorts of different mix and matches to see if maybe I'm not doing it right but no cigar.
I had installed my game from Origin quite sometime ago, all patches up to date and everything had been installed as laid out in your directions. Maybe I'm missing something here? I'm very no good at modding so perhaps I made a simple mistake~

((If this is an already answered question I apologize, I doublechecked in archives but maybe I missed it!))

...hold CTRL? ._.
Having trouble with the Spore ModAPI Launcher Kit? Let us know here!

If you're reading this, you have my permission to build off of my mods as long as I am credited. Please don't mirror my work unaltered, unless I no longer provide a working download.

oblatrate
Poster of the New User Apocalypse
Poster of the New User Apocalypse
Posts: 3
Joined: Mon Jan 04, 2016 10:43 am

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread postby oblatrate » Wed Jan 06, 2016 10:22 am

I feel so silly, I never thought to continue to hold CTRL since all other limbs attach at will no problem! What an easy fix, feel bad for bothering you over something so simple lol
Thank you so much!!!

User avatar
rob55rod
Tech Support
Tech Support
Sergeant Major of the Davo Army
Sergeant Major of the Davo Army
Posts: 3776
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread postby rob55rod » Wed Jan 06, 2016 10:53 am

oblatrate wrote:I feel so silly, I never thought to continue to hold CTRL since all other limbs attach at will no problem! What an easy fix, feel bad for bothering you over something so simple lol
Thank you so much!!!

Eh, not a problem. Anything you need help with, I'll be here to help you out. Don't feel bad for asking about small issues :lol:
Having trouble with the Spore ModAPI Launcher Kit? Let us know here!

If you're reading this, you have my permission to build off of my mods as long as I am credited. Please don't mirror my work unaltered, unless I no longer provide a working download.

Daemon15
Poster of the New User Apocalypse
Poster of the New User Apocalypse
Posts: 1
Joined: Tue Jan 26, 2016 12:16 pm

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread postby Daemon15 » Tue Jan 26, 2016 3:27 pm

Hello I have b eed of a hand, I have installed dark injection, at the beginning I have took the 2013_DI_NC.package (C) for complexitée and extended limits, but I had problems with the cameras! suddenly I have changed with this one 2015_DI_NC_FIX.package, the mod it's a very well put fonctionnées except I is not extended the limits so I can put as much of elements I want, but I can not faires not large creatures in lengths as DarkEdge and I can not use the duplication! How Does it ? and how to extend the boundaries?

oblatrate
Poster of the New User Apocalypse
Poster of the New User Apocalypse
Posts: 3
Joined: Mon Jan 04, 2016 10:43 am

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread postby oblatrate » Wed Jan 27, 2016 1:58 pm

I have another question, sorry. Or, more of a story I suppose as I'm sure there's no fix knowing what I've seen in FAQ.
My invisible limbs have always been invisible but one day I decided to try out making Spore not fullscreen. Suddenly my invisible limbs turned visible-that dreaded grey limb. I set everything back to normal but to no avail.
Totally killed my vibe. I know there has been no fix other than graphics card but thought I'd mention my little experience. Hoping they'll get invisible again. My computer is also pretty old, so maybe the graphics card decided to give out with that now.

User avatar
rob55rod
Tech Support
Tech Support
Sergeant Major of the Davo Army
Sergeant Major of the Davo Army
Posts: 3776
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread postby rob55rod » Wed Jan 27, 2016 4:29 pm

oblatrate wrote:I have another question, sorry. Or, more of a story I suppose as I'm sure there's no fix knowing what I've seen in FAQ.
My invisible limbs have always been invisible but one day I decided to try out making Spore not fullscreen. Suddenly my invisible limbs turned visible-that dreaded grey limb. I set everything back to normal but to no avail.
Totally killed my vibe. I know there has been no fix other than graphics card but thought I'd mention my little experience. Hoping they'll get invisible again. My computer is also pretty old, so maybe the graphics card decided to give out with that now.

Yeah, I have no idea. These limbs make no sense. They should still be invisible ingame...
Having trouble with the Spore ModAPI Launcher Kit? Let us know here!

If you're reading this, you have my permission to build off of my mods as long as I am credited. Please don't mirror my work unaltered, unless I no longer provide a working download.

User avatar
Exo-Unit
Recruit
Recruit
Posts: 5
Joined: Sun Feb 28, 2016 4:32 pm

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread postby Exo-Unit » Sun Feb 28, 2016 4:39 pm

Currently field testing using Dark Injection on Origin version (was using Steam before). So far it seems to be working. Encountered a problem early on, most of the functions of the mod work. However the interface in-game or in creature-editor (buttons, icons, preview displays of creatures) seem to either be scrambled or not displaying correctly. I tried searching around on the forum for anything relating to this, even the FAQ, but there's no indication of this.

Currently using Spore w/ C&C with GA. Dark Files are installed in GA Data folder.

Update - Hmm, not sure how, maybe it was something to do with the load order. Most the buttons and interface seems fixed, except for most of the menu and other areas 'whited out', also icons below the Complexity meter are also scrambled.

User avatar
rob55rod
Tech Support
Tech Support
Sergeant Major of the Davo Army
Sergeant Major of the Davo Army
Posts: 3776
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread postby rob55rod » Sun Feb 28, 2016 5:12 pm

Exo-Unit wrote:Currently field testing using Dark Injection on Origin version (was using Steam before). So far it seems to be working. Encountered a problem early on, most of the functions of the mod work. However the interface in-game or in creature-editor (buttons, icons, preview displays of creatures) seem to either be scrambled or not displaying correctly. I tried searching around on the forum for anything relating to this, even the FAQ, but there's no indication of this.

Currently using Spore w/ C&C with GA. Dark Files are installed in GA Data folder.

Update - Hmm, not sure how, maybe it was something to do with the load order. Most the buttons and interface seems fixed, except for most of the menu and other areas 'whited out', also icons below the Complexity meter are also scrambled.

Hmm...odd. Care to provide screenshots? ._._.
Having trouble with the Spore ModAPI Launcher Kit? Let us know here!

If you're reading this, you have my permission to build off of my mods as long as I am credited. Please don't mirror my work unaltered, unless I no longer provide a working download.

User avatar
Exo-Unit
Recruit
Recruit
Posts: 5
Joined: Sun Feb 28, 2016 4:32 pm

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread postby Exo-Unit » Sun Feb 28, 2016 5:28 pm

Hmm...odd. Care to provide screenshots? ._._.


The scrambled creature stats in the top right
https://www.dropbox.com/s/kanwtwm4elzao ... 1.jpg?dl=0

The odd scrambled interface on the lower left in the test section of the creature editor.
https://www.dropbox.com/s/ahabb5jqchd17 ... 2.jpg?dl=0

And the odd white out texture background issue with most previewed creatures and certain icons.
https://www.dropbox.com/s/zx9axowjknj7n ... 3.jpg?dl=0

I was testing the later version of DI_NC version 9r 2015 but didn't seem to work, only the old 2013 version allowed me infinite complexity and height.

Also the Main Spore and C&C folders are installed in the same origin directory where I'm modifying the GA version

User avatar
rob55rod
Tech Support
Tech Support
Sergeant Major of the Davo Army
Sergeant Major of the Davo Army
Posts: 3776
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread postby rob55rod » Sun Feb 28, 2016 6:52 pm

Exo-Unit wrote:
Hmm...odd. Care to provide screenshots? ._._.


The scrambled creature stats in the top right
https://www.dropbox.com/s/kanwtwm4elzao ... 1.jpg?dl=0

The odd scrambled interface on the lower left in the test section of the creature editor.
https://www.dropbox.com/s/ahabb5jqchd17 ... 2.jpg?dl=0

And the odd white out texture background issue with most previewed creatures and certain icons.
https://www.dropbox.com/s/zx9axowjknj7n ... 3.jpg?dl=0

I was testing the later version of DI_NC version 9r 2015 but didn't seem to work, only the old 2013 version allowed me infinite complexity and height.

Also the Main Spore and C&C folders are installed in the same origin directory where I'm modifying the GA version

Odd. Normally, that only happens when you use a UI mod based on an outdated version of the game, remove Spore_EP1_Data.package , or have a damaged game install ._.

Might any of those things be true?
Having trouble with the Spore ModAPI Launcher Kit? Let us know here!

If you're reading this, you have my permission to build off of my mods as long as I am credited. Please don't mirror my work unaltered, unless I no longer provide a working download.

User avatar
Exo-Unit
Recruit
Recruit
Posts: 5
Joined: Sun Feb 28, 2016 4:32 pm

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread postby Exo-Unit » Sun Feb 28, 2016 7:02 pm

Odd. Normally, that only happens when you use a UI mod based on an outdated version of the game, remove Spore_EP1_Data.package , or have a damaged game install ._.

Might any of those things be true?


I'll try a full reinstall of the main spore and adventures.

There might have been a issue most likely as I didn't uninstall the Steam versions. Which is why the Origin didn't allow me to install after purchasing them.

I'll report back if either reinstalling failed/worked or deleting EP1 Data package had any effect.

User avatar
rob55rod
Tech Support
Tech Support
Sergeant Major of the Davo Army
Sergeant Major of the Davo Army
Posts: 3776
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread postby rob55rod » Mon Feb 29, 2016 6:04 am

Exo-Unit wrote:
Odd. Normally, that only happens when you use a UI mod based on an outdated version of the game, remove Spore_EP1_Data.package , or have a damaged game install ._.

Might any of those things be true?


I'll try a full reinstall of the main spore and adventures.

There might have been a issue most likely as I didn't uninstall the Steam versions. Which is why the Origin didn't allow me to install after purchasing them.

I'll report back if either reinstalling failed/worked or deleting EP1 Data package had any effect.

k

Also DON'T DELETE ANYTHING!! (I said deleting that package CAUSES the bug to occur ._. )
Having trouble with the Spore ModAPI Launcher Kit? Let us know here!

If you're reading this, you have my permission to build off of my mods as long as I am credited. Please don't mirror my work unaltered, unless I no longer provide a working download.

User avatar
Snaid1
Staff Sergeant
Staff Sergeant
Posts: 151
Joined: Tue Jul 27, 2010 10:52 am

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread postby Snaid1 » Tue Mar 01, 2016 9:26 am

Exo-Unit wrote:
Hmm...odd. Care to provide screenshots? ._._.


The scrambled creature stats in the top right
https://www.dropbox.com/s/kanwtwm4elzao ... 1.jpg?dl=0

The odd scrambled interface on the lower left in the test section of the creature editor.
https://www.dropbox.com/s/ahabb5jqchd17 ... 2.jpg?dl=0

And the odd white out texture background issue with most previewed creatures and certain icons.
https://www.dropbox.com/s/zx9axowjknj7n ... 3.jpg?dl=0

I was testing the later version of DI_NC version 9r 2015 but didn't seem to work, only the old 2013 version allowed me infinite complexity and height.

Also the Main Spore and C&C folders are installed in the same origin directory where I'm modifying the GA version


I had it happen after windows 10 decided to upgrade last November. Uninstalling everything and reinstalling it fixed that bug for me. just make sure you back up important folders (like creations) before you do so.

User avatar
Exo-Unit
Recruit
Recruit
Posts: 5
Joined: Sun Feb 28, 2016 4:32 pm

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread postby Exo-Unit » Sat Mar 05, 2016 3:15 am

It seems to be a success.

At least so far. Completely erased Spore data from existence from my system [App data and also Registry]. There was difficulty reinstalling the main spore via origin, however changing the main directory of where it's installed and downloaded allowed me to redownload and install it without issue. The GA version downloaded and updated as well and nothing weird with the C&C pack. (May want to put the directory alteration as a suggested solution for those who have similar install issues with spore origin)

Running GA without mods worked fine with no distorted graphical icons and such, and I can gladly say the same after doing so with the Dark Injection mod packages. I'll begin my first few runs and confirm if it was a complete success.

I appreciate the assistance the support team has provided.

User avatar
Davo
The Boss
The Boss
Sergeant Major of the Davo Army
Sergeant Major of the Davo Army
Posts: 2180
Joined: Sun Dec 27, 2009 1:36 am
Location: NOLA
Contact:

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread postby Davo » Fri Mar 11, 2016 6:22 pm

Q: Why aren't the invisible parts invisible like in DarkEdgeTV's videos?
A: I'm not sure. Just keep in mind that DarkEdgeTV is the exception, not the rule. They should still be invisible in the Sporepedia, adventures, and savegames, unles you're really unlucky. Regardles, I've tried damn-near everything I can think of to fix this, but nothing works :/


could it be resolution/game/texture/graphic/quality? Like setting to low def graphics would do this...?
Support my Site via Adf.ly : View the Ad or Skip the Ad


User avatar
DarkEdgeTV
First Class
First Class
Posts: 58
Joined: Fri Jul 05, 2013 5:26 am
Contact:

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread postby DarkEdgeTV » Fri Mar 11, 2016 6:29 pm

I've literally only just seen this now on the front-page activity, otherwise I'd have answered sooner. I hope this is still relevant.

Q: Why aren't the invisible parts invisible like in DarkEdgeTV's videos?
A: I'm not sure. Just keep in mind that DarkEdgeTV is the exception, not the rule. They should still be invisible in the Sporepedia, adventures, and savegames, unles you're really unlucky. Regardles, I've tried damn-near everything I can think of to fix this, but nothing works :/


Try switching your Lighting Quality option to High/Max in the settings. I found when I switch mine down to medium or low, the invisible limbs become visible. I would really love some confirmation that setting the Lighting Quality to High is what we need to get the invisible limbs to become invisible (hopefully PC quality wont matter).

User avatar
rob55rod
Tech Support
Tech Support
Sergeant Major of the Davo Army
Sergeant Major of the Davo Army
Posts: 3776
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread postby rob55rod » Fri Mar 11, 2016 8:52 pm

DarkEdgeTV wrote:I've literally only just seen this now on the front-page activity, otherwise I'd have answered sooner. I hope this is still relevant.

Q: Why aren't the invisible parts invisible like in DarkEdgeTV's videos?
A: I'm not sure. Just keep in mind that DarkEdgeTV is the exception, not the rule. They should still be invisible in the Sporepedia, adventures, and savegames, unles you're really unlucky. Regardles, I've tried damn-near everything I can think of to fix this, but nothing works :/


Try switching your Lighting Quality option to High/Max in the settings. I found when I switch mine down to medium or low, the invisible limbs become visible. I would really love some confirmation that setting the Lighting Quality to High is what we need to get the invisible limbs to become invisible (hopefully PC quality wont matter).

._.

I was there for that stream. I and others have experimented with that since then, to no avail D:

Davo wrote:
Q: Why aren't the invisible parts invisible like in DarkEdgeTV's videos?
A: I'm not sure. Just keep in mind that DarkEdgeTV is the exception, not the rule. They should still be invisible in the Sporepedia, adventures, and savegames, unles you're really unlucky. Regardles, I've tried damn-near everything I can think of to fix this, but nothing works :/


could it be resolution/game/texture/graphic/quality? Like setting to low def graphics would do this...?

No. Unless you're DarkEdgeTV, that is ._.
Having trouble with the Spore ModAPI Launcher Kit? Let us know here!

If you're reading this, you have my permission to build off of my mods as long as I am credited. Please don't mirror my work unaltered, unless I no longer provide a working download.

User avatar
DarkEdgeTV
First Class
First Class
Posts: 58
Joined: Fri Jul 05, 2013 5:26 am
Contact:

Re: Official Dark Injection FAQ! Answers and Fixes!

Unread postby DarkEdgeTV » Sat Mar 12, 2016 5:11 am

Bah, typical! And yeah I remember the Stream (also experimented with it some more yesterday), and well it's a shame that wont solve the issue.

Guess I am lucky ><


Return to “FAQ, Info, and Help”