Spore ModAPI

Download tools like Sporemaster and get the latest patches.
Poster of the New User Apocalypse

Poster of the New User Apocalypse

300
Posts: 2
Joined: Wed Jan 23, 2019 2:17 am

Re: Spore ModAPI

Unread postby 300 » Wed Jan 23, 2019 2:21 am

My problem (before, i have Russian Spore version, but im delete it and reinstall full English version, but it still don't work. I have latest Spore GA version):

    https://youtu.be/hrMWVS_k2b0

Tech Support

Tech Support

rob55rod
User avatar
Posts: 3578
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.

Re: Spore ModAPI

Unread postby rob55rod » Thu Jan 24, 2019 12:52 pm

300 wrote:-snip-

Well first off, don't put the .sporemod file into your DataEP1 folder.


DragonKing wrote:-snip-

Image
Image
To anyone encountering either of these two error messages, we've recently released an update which should address the most prevalent causes for this issue, so just run the Spore ModAPI Launcher again, and it will update automatically. This should resolve the problem, but please let us know if it still doesn't work afterwards.

Poster of the New User Apocalypse

Poster of the New User Apocalypse

Rxntao
User avatar
Posts: 1
Joined: Thu Jan 24, 2019 4:17 pm

Re: Spore ModAPI

Unread postby Rxntao » Thu Jan 24, 2019 4:57 pm

The Launcher wont launch with the latest version of Dark Injection for some reason and yes, i meant Dark Injection 2.3.0

RE: just read most of the forum and do you know when that bugfix will be out?

Tech Support

Tech Support

rob55rod
User avatar
Posts: 3578
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.

Re: Spore ModAPI

Unread postby rob55rod » Fri Jan 25, 2019 4:58 am

Rxntao wrote:The Launcher wont launch with the latest version of Dark Injection for some reason and yes, i meant Dark Injection 2.3.0

Care to elaborate on what you mean by "won't Launch"?

Rxntao wrote:RE: just read most of the forum and do you know when that bugfix will be out?

If by that you mean the ModAPI Launcher Kit update I mentioned in the post above yours, it came out a few minutes before I posted that message.

Recruit

Recruit

Beohel
Posts: 5
Joined: Thu Jan 10, 2019 3:48 am

Re: Spore ModAPI

Unread postby Beohel » Sun Jan 27, 2019 12:31 am

I installed the newest version of the API, but it seems to be actively causing my game to crash. Even when I uninstall every mod, it won't function.

Is there any way I can fix this issue?

Recruit

Recruit

Beohel
Posts: 5
Joined: Thu Jan 10, 2019 3:48 am

Re: Spore ModAPI

Unread postby Beohel » Sun Jan 27, 2019 12:34 am

Spore Mod API.PNG

Spore Mod API 2.PNG
You do not have the required permissions to view the files attached to this post.

Recruit

Recruit

Beohel
Posts: 5
Joined: Thu Jan 10, 2019 3:48 am

Re: Spore ModAPI

Unread postby Beohel » Sun Jan 27, 2019 12:34 am

Some screenshots, btw

Poster of the New User Apocalypse

Poster of the New User Apocalypse

Khaimera
Posts: 2
Joined: Sun Jan 27, 2019 3:06 am

Re: Spore ModAPI

Unread postby Khaimera » Sun Jan 27, 2019 3:14 am

Hey fellas, new here, and I wanted to ask for help with this Mod API. Everything installed correctly, and I even got the mods to install correctly as well. But when I start up the launcher, it causes GA to get stuck in a Running loop (I have Spore on Steam), and it only stops if I exit Steam entirely. The launcher also gives me this
Capture.PNG


I'm currently running Windows 10, and I've already made an exception in the Fire Wall, and restarted my PC a few times just to be sure. I even Verified the file integrity as well.
You do not have the required permissions to view the files attached to this post.

Tech Support

Tech Support

rob55rod
User avatar
Posts: 3578
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.

Re: Spore ModAPI

Unread postby rob55rod » Sun Jan 27, 2019 10:06 am

Khaimera wrote:-snip-

Do you have Dark Injection installed? If so, try upgrading to Dark Injection 9.r Public Beta 2.3.2, let me know if that helps.

Beohel wrote:I installed the newest version of the API, but it seems to be actively causing my game to crash. Even when I uninstall every mod, it won't function.
Is there any way I can fix this issue?

That's...a bit weird, to say the least. Any chance you'd mind meeting up on The Spore Modding Community Discord Server's modding support channel? I think it'll be easier to diagnose what's going on here through a more efficient means of communication, rather than this clunky forum, if you're up to it.

Poster of the New User Apocalypse

Poster of the New User Apocalypse

Khaimera
Posts: 2
Joined: Sun Jan 27, 2019 3:06 am

Re: Spore ModAPI

Unread postby Khaimera » Sun Jan 27, 2019 11:09 am

rob55rod wrote:
Khaimera wrote:-snip-

Do you have Dark Injection installed? If so, try upgrading to Dark Injection 9.r Public Beta 2.3.2, let me know if that helps.

Beohel wrote:I installed the newest version of the API, but it seems to be actively causing my game to crash. Even when I uninstall every mod, it won't function.
Is there any way I can fix this issue?

That's...a bit weird, to say the least. Any chance you'd mind meeting up on The Spore Modding Community Discord Server's modding support channel? I think it'll be easier to diagnose what's going on here through a more efficient means of communication, rather than this clunky forum, if you're up to it.


Yeah I have Dark Injection installed, and it always pops up with that snippet I posted up. I've uninstalled and reinstalled the entire thing (mods, the launcher, everything) and still the same issue. Maybe its because I have it on Steam?

Tech Support

Tech Support

rob55rod
User avatar
Posts: 3578
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.

Re: Spore ModAPI

Unread postby rob55rod » Sun Jan 27, 2019 12:02 pm

Alright, that's one down, one to go.

Poster of the New User Apocalypse

Poster of the New User Apocalypse

Bloodfallen1708
Posts: 1
Joined: Sun Jan 27, 2019 10:05 pm

Re: Spore ModAPI

Unread postby Bloodfallen1708 » Sun Jan 27, 2019 10:08 pm

Halp! What is dis and how do I fix? My game refuses to open through the launcher and it keeps demanding I post an SS of the error message that pops up. ;-;
You do not have the required permissions to view the files attached to this post.

Tech Support

Tech Support

rob55rod
User avatar
Posts: 3578
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.

Re: Spore ModAPI

Unread postby rob55rod » Mon Jan 28, 2019 1:58 pm

Bloodfallen1708 wrote:Halp! What is dis and how do I fix? My game refuses to open through the launcher and it keeps demanding I post an SS of the error message that pops up. ;-;

We're currently investigating the symptom you're dealing with. I'll post something here once a fix is available, or if I happen to need more information from you.

Poster of the New User Apocalypse

Poster of the New User Apocalypse

Elzhas
Posts: 4
Joined: Thu Jan 31, 2019 10:55 am

Re: Spore ModAPI

Unread postby Elzhas » Sat Feb 02, 2019 10:44 am

Hello can you help me? I install dark injection with spore API and launch it and give a error

Tech Support

Tech Support

rob55rod
User avatar
Posts: 3578
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.

Re: Spore ModAPI

Unread postby rob55rod » Sat Feb 02, 2019 12:04 pm

Elzhas wrote:Hello can you help me? I install dark injection with spore API and launch it and give a error

Post a screenshot of the error itself, then I'll be happy to see what I can do.

Poster of the New User Apocalypse

Poster of the New User Apocalypse

Elzhas
Posts: 4
Joined: Thu Jan 31, 2019 10:55 am

Re: Spore ModAPI

Unread postby Elzhas » Sun Feb 03, 2019 12:58 am

https://my.mail.ru/mail/elzhas2011/phot ... o/389.html
sorry i dont know how load image from computer

Tech Support

Tech Support

rob55rod
User avatar
Posts: 3578
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.

Re: Spore ModAPI

Unread postby rob55rod » Sun Feb 03, 2019 6:05 am

Elzhas wrote:https://my.mail.ru/mail/elzhas2011/photo/_mypagephoto/389.html
sorry i dont know how load image from computer

That's fine, I can work with this.

I've just updated the ModAPI Launcher Kit to give us more information about the problem. It will now show several MessageBoxes instead of just the one you saw. Could you please provide screenshots of all of them?



(also totally unrelated but uh, nice Visual Style)

Poster of the New User Apocalypse

Poster of the New User Apocalypse

Elzhas
Posts: 4
Joined: Thu Jan 31, 2019 10:55 am

Re: Spore ModAPI

Unread postby Elzhas » Sun Feb 03, 2019 7:01 am

i forget to ask ModAPI work with R.G.Mechanics (pirated version spore)?

Tech Support

Tech Support

rob55rod
User avatar
Posts: 3578
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.

Re: Spore ModAPI

Unread postby rob55rod » Sun Feb 03, 2019 7:37 am

Elzhas wrote:i forget to ask ModAPI work with R.G.Mechanics (pirated version spore)?

I don't support piracy, due to both moral and technical obstacles presented by it.

Recruit

Recruit

gr00fchu
User avatar
Posts: 12
Joined: Sat Feb 03, 2018 12:29 pm

Re: Spore ModAPI

Unread postby gr00fchu » Sun Feb 03, 2019 9:33 am

SporeModAPI won't launch for me for some reason and displays this message box
You do not have the required permissions to view the files attached to this post.


Return to “Tools & Patches”

Who is online

Users browsing this forum: No registered users and 5 guests