Spore ModAPI

Download tools like Sporemaster and get the latest patches.
User avatar
VanillaCold
Staff Sergeant
Staff Sergeant
Posts: 199
Joined: Fri Nov 02, 2018 2:36 pm
Contact:

Re: Spore ModAPI

Unread postby VanillaCold » Thu Apr 18, 2019 5:48 am

Risis4 wrote:There`s no rest, thats the part that matters

The whole error is the "part that matters".
Creator of Solar Spore, Adventure Water and Spaceplanes.

My main account broke a while ago, so I created this alt.

User avatar
rob55rod
Tech Support
Tech Support
Sergeant Major of the Davo Army
Sergeant Major of the Davo Army
Posts: 3877
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.

Re: Spore ModAPI

Unread postby rob55rod » Thu Apr 18, 2019 8:18 am

Risis4 wrote:There`s no rest, thats the part that matters
Hmmmm, then I wonder why I would asked for the entire error? Oh yeah, maybe because the entire error matters. Which it does. I wouldn't have asked for it if it didn't.


Risis4 wrote:i know DI isn`t`the problem, but with the 2.1.6 it will works :S
No, the Spore ModAPI Launcher won't work even if you downgrade to DI 9.r Public Beta 2.1.6, that's not how it works. That's not how any of this works.
Having trouble with the Spore ModAPI Launcher Kit? Let us know here!

If you're reading this, you have my permission to build off of my mods as long as I am credited. Please don't mirror my work unaltered, unless I no longer provide a working download.

supercyclotosaurus
Recruit
Recruit
Posts: 8
Joined: Sat Dec 22, 2018 9:58 am

Re: Spore ModAPI

Unread postby supercyclotosaurus » Thu Apr 18, 2019 9:14 am

when i launch spore mod api it acts like i dont have spore creepy and cute even though i do. any thing to fix that?

supercyclotosaurus
Recruit
Recruit
Posts: 8
Joined: Sat Dec 22, 2018 9:58 am

Re: Spore ModAPI

Unread postby supercyclotosaurus » Thu Apr 18, 2019 9:15 am

is there a file i need?

rstreamflower
Poster of the New User Apocalypse
Poster of the New User Apocalypse
Posts: 2
Joined: Sat Mar 30, 2019 12:42 pm

Re: Spore ModAPI

Unread postby rstreamflower » Thu Apr 18, 2019 9:54 am

Some of the creature parts in dark in jact are missing abilties they had in the non-modded version of spore. Can whoever made Dark Injection fix that?

supercyclotosaurus
Recruit
Recruit
Posts: 8
Joined: Sat Dec 22, 2018 9:58 am

Re: Spore ModAPI

Unread postby supercyclotosaurus » Thu Apr 18, 2019 5:41 pm

rstreamflower wrote:Some of the creature parts in dark in jact are missing abilties they had in the non-modded version of spore. Can whoever made Dark Injection fix that?

im pretty sure you should ask that on the dark injection help page

Risis4
Recruit
Recruit
Posts: 17
Joined: Mon Apr 01, 2019 12:38 pm

Re: Spore ModAPI

Unread postby Risis4 » Thu Apr 18, 2019 9:08 pm

rob55rod wrote:
Risis4 wrote:There`s no rest, thats the part that matters
Hmmmm, then I wonder why I would asked for the entire error? Oh yeah, maybe because the entire error matters. Which it does. I wouldn't have asked for it if it didn't.


Risis4 wrote:i know DI isn`t`the problem, but with the 2.1.6 it will works :S
No, the Spore ModAPI Launcher won't work even if you downgrade to DI 9.r Public Beta 2.1.6, that's not how it works. That's not how any of this works.
Last edited by Risis4 on Thu Apr 18, 2019 9:21 pm, edited 1 time in total.

Risis4
Recruit
Recruit
Posts: 17
Joined: Mon Apr 01, 2019 12:38 pm

Re: Spore ModAPI

Unread postby Risis4 » Thu Apr 18, 2019 9:21 pm

Image


Finally, i said the other part didn`t matters cause it is in spanish :S
I mean a DI that don`t need mod APi
anyway there are other users with that error, except that they have more errors than me, i only have that one with the "splitwirez" (i dont have any user with that name )

supercyclotosaurus
Recruit
Recruit
Posts: 8
Joined: Sat Dec 22, 2018 9:58 am

Re: Spore ModAPI

Unread postby supercyclotosaurus » Fri Apr 19, 2019 8:46 am

supercyclotosaurus wrote:when i launch spore mod api it acts like i dont have spore creepy and cute even though i do. any thing to fix that?

is dont mean this to sound rude if it does but is anyone going to help me?

User avatar
rob55rod
Tech Support
Tech Support
Sergeant Major of the Davo Army
Sergeant Major of the Davo Army
Posts: 3877
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.

Re: Spore ModAPI

Unread postby rob55rod » Fri Apr 19, 2019 2:00 pm

Risis4 wrote:Image
Finally, i said the other part didn`t matters cause it is in spanish :S
Okay, that is significantly more informative. Thank you.


Risis4 wrote:I mean a DI that don`t need mod APi
Yes, I know that. That attitude is exactly the problem - your request is analogous to using paper mache to cover up a pothole in a road - yes, the visible symptom would be resolved, but the underlying problem would remain, and it's only a matter of time before someone blows a tire over it or whatever. Dark Injection isn't the only ModAPI mod out there, after all.
Anywaves, let's see if we can actually get this problem solved...where did you say you installed Spore from? Steam? GOG? Origin? Disks?


Risis4 wrote:anyway there are other users with that error, except that they have more errors than me,
I am aware of that.


Risis4 wrote:i only have that one with the "splitwirez" (i dont have any user with that name )
Nobody has a user with that name except me. You're not supposed to, and if you did, it'd be 100% by coincidence. Those paths are just there to tell us more about where in the source code the problem occurred, and since the Spore ModAPI Launcher Kit was compiled on my computer, the paths reflect my username and setup.


supercyclotosaurus wrote:
supercyclotosaurus wrote:when i launch spore mod api it acts like i dont have spore creepy and cute even though i do. any thing to fix that?

is dont mean this to sound rude if it does but is anyone going to help me?
I must've missed your earlier post, sorry about that. In any case, if I'm understanding you correctly, this issue actually has nothing to do with the Spore ModAPI Launcher Kit and everything to do with...well, Spore being Spore. (That is, unless you're implying you have more evidence than just "Creepy & Cute doesn't work now"?)
Having trouble with the Spore ModAPI Launcher Kit? Let us know here!

If you're reading this, you have my permission to build off of my mods as long as I am credited. Please don't mirror my work unaltered, unless I no longer provide a working download.

Risis4
Recruit
Recruit
Posts: 17
Joined: Mon Apr 01, 2019 12:38 pm

Re: Spore ModAPI

Unread postby Risis4 » Fri Apr 19, 2019 7:25 pm

rob55rod wrote:
Yes, I know that. That attitude is exactly the problem - your request is analogous to using paper mache to cover up a pothole in a road - yes, the visible symptom would be resolved, but the underlying problem would remain, and it's only a matter of time before someone blows a tire over it or whatever. Dark Injection isn't the only ModAPI mod out there, after all.
Anywaves, let's see if we can actually get this problem solved...where did you say you installed Spore from? Steam? GOG? Origin? Disks?


IDK if we are getting rude but....i just want to play with DI .-. dont want any problems sry

i did install spore from disks....

supercyclotosaurus
Recruit
Recruit
Posts: 8
Joined: Sat Dec 22, 2018 9:58 am

Re: Spore ModAPI

Unread postby supercyclotosaurus » Mon Apr 22, 2019 12:51 pm

does anyone know where i could ask about my problem

User avatar
rob55rod
Tech Support
Tech Support
Sergeant Major of the Davo Army
Sergeant Major of the Davo Army
Posts: 3877
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.

Re: Spore ModAPI

Unread postby rob55rod » Tue Apr 23, 2019 8:30 am

Risis4 wrote:IDK if we are getting rude but....i just want to play with DI .-. dont want any problems sry

I know, that's why I'm trying to identify the problem you're already facing: So we can resolve it - properly - and then you'll be able to play Spore with DI. Having taken another look at the error you posted - specifically the part you initially refused to provide - I think I know what the issue is. On that note...do you know the path to the folder you installed the Spore ModAPI Launcher Kit to?


supercyclotosaurus wrote:does anyone know where i could ask about my problem

If you're referring to the Creepy and Cute problem you mentioned earlier, that belongs in the Spore Help subforum, so create a thread there.
Having trouble with the Spore ModAPI Launcher Kit? Let us know here!

If you're reading this, you have my permission to build off of my mods as long as I am credited. Please don't mirror my work unaltered, unless I no longer provide a working download.

Risis4
Recruit
Recruit
Posts: 17
Joined: Mon Apr 01, 2019 12:38 pm

Re: Spore ModAPI

Unread postby Risis4 » Thu Apr 25, 2019 12:42 pm

rob55rod wrote:
Risis4 wrote:IDK if we are getting rude but....i just want to play with DI .-. dont want any problems sry

I know, that's why I'm trying to identify the problem you're already facing: So we can resolve it - properly - and then you'll be able to play Spore with DI. Having taken another look at the error you posted - specifically the part you initially refused to provide - I think I know what the issue is. On that note...do you know the path to the folder you installed the Spore ModAPI Launcher Kit to?


It automatically installed in my programdata folder ( I didn`t configure it to install in a different part than the default )

RaiaNixy
Poster of the New User Apocalypse
Poster of the New User Apocalypse
Posts: 2
Joined: Thu Apr 25, 2019 4:17 pm

Re: Spore ModAPI

Unread postby RaiaNixy » Thu Apr 25, 2019 4:36 pm

hi, I have a problem...
When I open the spore I get an error that the tool of the modAPI Launcher or something was not detected and I got this message
file:///C:/Users/Familia/Desktop/Sin%20t%C3%ADtulo.png
file:///C:/Users/Familia/Desktop/1.png

I would really appreciate it if you would help me
Thank you

User avatar
rob55rod
Tech Support
Tech Support
Sergeant Major of the Davo Army
Sergeant Major of the Davo Army
Posts: 3877
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.

Re: Spore ModAPI

Unread postby rob55rod » Sat Apr 27, 2019 3:28 am

RaiaNixy wrote:hi, I have a problem...
When I open the spore I get an error that the tool of the modAPI Launcher or something was not detected and I got this message
file:///C:/Users/Familia/Desktop/Sin%20t%C3%ADtulo.png
file:///C:/Users/Familia/Desktop/1.png

I would really appreciate it if you would help me
Thank you

Any chance you could provide screenshots, instead of what I can only assume are the locations of screenshots on your computer, which only you can access?
Having trouble with the Spore ModAPI Launcher Kit? Let us know here!

If you're reading this, you have my permission to build off of my mods as long as I am credited. Please don't mirror my work unaltered, unless I no longer provide a working download.

RaiaNixy
Poster of the New User Apocalypse
Poster of the New User Apocalypse
Posts: 2
Joined: Thu Apr 25, 2019 4:17 pm

Re: Spore ModAPI

Unread postby RaiaNixy » Sat Apr 27, 2019 7:12 am

How do I put screenshots? try but I can not

User avatar
rob55rod
Tech Support
Tech Support
Sergeant Major of the Davo Army
Sergeant Major of the Davo Army
Posts: 3877
Joined: Sat Jul 02, 2011 9:50 am
Location: Zelem's Nexus, rebuilding.

Re: Spore ModAPI

Unread postby rob55rod » Sat Apr 27, 2019 1:09 pm

RaiaNixy wrote:How do I put screenshots? try but I can not

You have to upload them to an image hosting website, and then post those links here. If you're not sure what site to use, https://imgur.com/ is simple enough.
Having trouble with the Spore ModAPI Launcher Kit? Let us know here!

If you're reading this, you have my permission to build off of my mods as long as I am credited. Please don't mirror my work unaltered, unless I no longer provide a working download.

Risis4
Recruit
Recruit
Posts: 17
Joined: Mon Apr 01, 2019 12:38 pm

Re: Spore ModAPI

Unread postby Risis4 » Sat Apr 27, 2019 2:46 pm

Is Tere any fix for my error? Or some way to install the modapi to make it work in a manual way?

User avatar
VanillaCold
Staff Sergeant
Staff Sergeant
Posts: 199
Joined: Fri Nov 02, 2018 2:36 pm
Contact:

Re: Spore ModAPI

Unread postby VanillaCold » Sat Apr 27, 2019 2:53 pm

supercyclotosaurus wrote:does anyone know where i could ask about my problem

Like what Rob said, it's probably just Spore being itself and breaking.
However, I made a guide on how to fix it here: https://steamcommunity.com/sharedfiles/ ... 1263748057
Creator of Solar Spore, Adventure Water and Spaceplanes.

My main account broke a while ago, so I created this alt.


Return to “Tools & Patches”